<!DOCTYPE html> <html lang="en-US"><head itemid='' itemscope itemtype='http://schema.org/SpeakableSpecification'> <meta charset="UTF-8"/> <meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"> <meta name="language" content="English (United States), en-US"/> <meta http-equiv="Content-Language" content="en-US"/> <meta http-equiv="X-UA-Compatible" content="IE=edge"/> <title>Who will be the top rookie in fantasy? Experts debate - Baltimore Sun</title> <meta name="copyright" content="Copyright (c) 2020, Baltimore Sun"/> <meta name="y_key" content="cee2fe4077f8d050"/> <meta name="msvalidate.01" content="AAC9C18F70AC386BC4DCF4DDF9BF1786"/> <meta name="distribution" content="global"/> <meta name="rating" content="general"/> <meta name="keywords" content=""> <meta name="news_keywords" content=""/> <meta name="date" content="2020-05-04T16:10:57.789Z"/> <meta itemprop="description" name="description" content="The 2020 NFL Draft class was loaded with talent at wide receiver, but our experts don’t think a WR will be the top rookie in fantasy football this season."/> <meta name="googlebot-news" content="index"/> <meta name="twitter:title" content="Who will be the top rookie in fantasy? Experts debate"/> <meta name="twitter:image" content="https://www.baltimoresun.com/resizer/Vjl8OkN2q183VC-l4GeNoPpy9zk=/1200x0/top/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/ZOE22S7RC5HBLK5IFOWDVDXXW4.jpg"/> <meta name="twitter:description" content="The 2020 NFL Draft class was loaded with talent at wide receiver, but our experts don’t think a WR will be the top rookie in fantasy football this season."/> <meta name="twitter:card" content="summary_large_image"> <meta name="twitter:site" content="@baltimoresun"/> <meta name="twitter:creator" content="@baltimoresun"> <meta name="fb_title" content="Who will be the top rookie in fantasy? Experts debate"/> <meta property="og:url" content="https://www.baltimoresun.com/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200504-y7erqozqynfgjot47n3axky2je-story.html"/> <meta property="og:title" content="Who will be the top rookie in fantasy? Experts debate"/> <meta itemprop="image" property="og:image" content="https://www.baltimoresun.com/resizer/Vjl8OkN2q183VC-l4GeNoPpy9zk=/1200x0/top/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/ZOE22S7RC5HBLK5IFOWDVDXXW4.jpg"/> <meta property="og:description" content="The 2020 NFL Draft class was loaded with talent at wide receiver, but our experts don’t think a WR will be the top rookie in fantasy football this season."/> <meta property="og:locale" content="en_US"/> <meta property="og:site_name" content="baltimoresun.com"/> <meta property="article:opinion" content="false"/> <meta property="og:type" content="article"/> <meta property="article:content_tier" content="metered"/> <meta property="fb:app_id" content="310302989040998"/> <meta property="fb:page_id" content="9299179711"/> <meta property="fb:pages" content="9299179711"/> <meta property="fb:admins" content="100000786395051"/> <meta property="article:tag" content=""> <meta property="article:section" content=", Gambling"> <meta name="author" content="Action Network Staff, The Action Network"> <meta name="apple-itunes-app" content="app-id=496681035, app-argument=http://www.baltimoresun.com/deeplinkidY7ERQOZQYNFGJOT47N3AXKY2JE"> <meta itemprop="cssSelector" content="h1"/> <meta itemprop="xpath" content="/html/head/meta[@name='description']/@content"/> <meta name="socialHeadlineField" content="web"/> <meta name="ztemplate" content="floating-rr6"/> <meta name="ptype" content="s"/> <link rel="dns-prefetch" href="//eb.trbas.com"/> <link rel="dns-prefetch" href="https://confiant-integrations.global.ssl.fastly.net"/> <link rel="preconnect" href="https://confiant-integrations.global.ssl.fastly.net"/> <link rel="dns-prefetch" href="//c.amazon-adsystem.com"/> <link rel="preconnect" href="//c.amazon-adsystem.com"/> <link rel="dns-prefetch" href="//aax.amazon-adsystem.com"/> <link rel="preconnect" href="//aax.amazon-adsystem.com"/> <link rel="dns-prefetch" href="//js-sec.indexww.com"/> <link rel="preconnect" href="//js-sec.indexww.com"/> <link rel="dns-prefetch" href="//as.casalemedia.com"/> <link rel="preconnect" href="//as.casalemedia.com"/> <link rel="dns-prefetch" href="//ads.rubiconproject.com"/> <link rel="preconnect" href="//ads.rubiconproject.com"/> <link rel="dns-prefetch" href="//optimized-by.rubiconproject.com"/> <link rel="preconnect" href="//optimized-by.rubiconproject.com"/> <link rel="dns-prefetch" href="//www.googletagservices.com"/> <link rel="preconnect" href="//www.googletagservices.com"/> <link rel="dns-prefetch" href="//securepubads.g.doubleclick.net"/> <link rel="preconnect" href="//securepubads.g.doubleclick.net"/> <link rel="preconnect" href="//tags.crwdcntrl.net"/> <link rel="preconnect" href="//bcp.crwdcntrl.net"/> <link rel="dns-prefetch" href="//tags.crwdcntrl.net"/> <link rel="dns-prefetch" href="//bcp.crwdcntrl.net"/> <link rel="preload" as="script" href="https://confiant-integrations.global.ssl.fastly.net/iPNj4YuXevI1r0eINnXsONTfIbc/gpt_and_prebid/config.js"/> <link rel="preload" as="script" href="//securepubads.g.doubleclick.net/tag/js/gpt.js"/> <link rel="preload" as="script" href="//js-sec.indexww.com/ht/htw-baltimore-sun.js"/> <link rel="preload" as="script" href="//c.amazon-adsystem.com/aax2/apstag.js"/><link rel="dns-prefetch" href="//js.matheranalytics.com"/> <link rel="preconnect" href="//js.matheranalytics.com"/> <link rel="dns-prefetch" href="//cdn.matheranalytics.com"/> <link rel="preconnect" href="//cdn.matheranalytics.com"/><link rel="dns-prefetch" href="//a.teads.tv"/> <link rel="dns-prefetch" href="//cdn2.teads.tv"/> <link rel="dns-prefetch" href="//sync.teads.tv"/> <link rel="dns-prefetch" href="//s8t.teads.tv"/> <link rel="dns-prefetch" href="//t.teads.tv"/><link rel="preload" href="/pb/resources/gdist/91591ceea4c96329b023/fonts/Spectral-400.woff " as="font" type="font/woff" crossorigin="anonymous"><link rel="preload" href="/pb/resources/gdist/91591ceea4c96329b023/fonts/Spectral-700.woff " as="font" type="font/woff" crossorigin="anonymous"><link rel="preload" href="/pb/resources/gdist/91591ceea4c96329b023/fonts/OpenSans-800.woff " as="font" type="font/woff" crossorigin="anonymous"><link rel="preload" href="/pb/resources/gdist/91591ceea4c96329b023/fonts/OpenSans-700.woff " as="font" type="font/woff" crossorigin="anonymous"><link rel="preload" href="/pb/resources/gdist/91591ceea4c96329b023/fonts/OpenSans-500.woff " as="font" type="font/woff" crossorigin="anonymous"><link rel="preload" href="/pb/resources/gdist/91591ceea4c96329b023/fonts/OpenSans-400.woff " as="font" type="font/woff" crossorigin="anonymous"><link rel="preload" href="/pb/resources/gdist/91591ceea4c96329b023/fonts/Lato-700.woff " as="font" type="font/woff" crossorigin="anonymous"><link rel="preload" href="/pb/resources/gdist/91591ceea4c96329b023/fonts/Lato-400.woff " as="font" type="font/woff" crossorigin="anonymous"> <link rel="icon" href="/pb/resources/images/balnews_icons/favicon.ico?v=224"/> <link rel="apple-touch-icon" sizes="57x57" href="/pb/resources/images/balnews_icons/57-iTunesArtwork.png?v=224"/> <link rel="apple-touch-icon" sizes="72x72" href="/pb/resources/images/balnews_icons/72-iTunesArtwork.png?v=224"/> <link rel="apple-touch-icon" sizes="114x114" href="/pb/resources/images/balnews_icons/114-iTunesArtwork.png?v=224"/> <link rel="apple-touch-icon" sizes="144x144" href="/pb/resources/images/balnews_icons/144-iTunesArtwork.png?v=224"/><link rel="canonical" href="https://www.actionnetwork.com/fantasy-football/rookie-fantasy-top-joe-burrow-cam-akers-clyde-edwards-helaire-2020"> <link rel="amphtml" href="https://www.baltimoresun.com/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200504-y7erqozqynfgjot47n3axky2je-story.html?outputType=amp"><link href="/pb/resources/gdist/91591ceea4c96329b023/balnews/balnews-framework91591ceea4c96329b023.css?v=224" rel="stylesheet"/> <link href="/pb/resources/gdist/91591ceea4c96329b023/balnews/balnews-features91591ceea4c96329b023.css?v=224" rel="stylesheet"/> <link href="/pb/resources/gdist/91591ceea4c96329b023/balnews/balnews-index91591ceea4c96329b023.css?v=224" rel="stylesheet"/> <link href="/pb/resources/gdist/91591ceea4c96329b023/balnews/balnews-services91591ceea4c96329b023.css?v=224" rel="stylesheet"/> <style>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</style> <script data-schema="NewsArticle" type="application/ld+json">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</script> <script data-schema="Organization" type="application/ld+json">{"@context":"http://schema.org","@type":"Organization","name":"Baltimore Sun","url":"https://www.baltimoresun.com","sameAs":["https://www.facebook.com/baltimoresun", "https://twitter.com/baltimoresun", "https://www.youtube.com/user/baltimoresun", "https://www.instagram.com/baltimoresun/", "https://vimeo.com/user2045206"],"logo":"https://www.baltimoresun.com/pb/resources/images/balnews_icons/logo_meta.png?token=123"}</script><script>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</script><script>var trb,i$;
i$={plugins:{},cache:{window:{innerHeight:window.innerHeight,innerWidth:window.innerWidth},document:{documentElement:{clientWidth:document.documentElement.clientWidth}}},$:i$&&i$.$||null,jQuery:i$&&i$.jQuery||null},trb={run:[],runInfuse:trb&&trb.runInfuse||[],registration:[],appendResource:function(a,b,c,d,e,f,g){var i=document.createElement(a);if("script"==a)i.src=b,i.async=c||!1,i.defer=c||d||!1,e&&i.addEventListener("load",e),f&&i.addEventListener("error",f);else if("link"==a)i.href=b,i.rel="stylesheet";
else return;if(12>trb.data.IEversion&&g)document.write(i.outerHTML);else{var j=document.head||document.documentElement;j[g?"insertBefore":"appendChild"](i,g?j.firstChild:null)}},metrics:{ga:!0},dpl:[],dpp:[],utils:{},browsersupport:{isMobile:function(){return/(android|bb\d+|meego).+mobile|bada\/|blackberry|fennec|iemobile|ip(hone|od|ad)|kindle|maemo|midp|mmp|netfront|opera m|palm|phone|p(ixi|re)\/|series(4|6)0|symbian|up\.(b|l)|vodafone|wap|windows (ce|phone)|android|playbook|silk/i.test(navigator.userAgent)},
IEversion:function(){if(("Microsoft Internet Explorer"==navigator.appName||"Netscape"==navigator.appName)&&/(?:MSIE |Trident.*rv:)([0-9\.]+)/.exec(navigator.userAgent))return parseFloat(RegExp.$1)}},data:{videos:{},embed:{},ads:{slotPrefix:"/4011/trb.baltimoresun"},metrics:{pbrd:"5",pvid:Date.now()+"_"+Math.floor(1E9*Math.random()),googleOp:"true",googleOpCon:"GTM-KGPD2QB",ga:!0},page:{siteName:"baltimoresun",ads:{options:{apfv:"false",apv:"false"},slot:"/4011/trb.baltimoresun/hp"}}},vendor:{snt:{}},
scrolled:!1,hasReadMore:!1},(trb.track=function(){trb.track.q.push(arguments)}).q=[];</script><script>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</script><script>var _createClass=function(){function a(a,b){for(var c,d=0;d<b.length;d++)c=b[d],c.enumerable=c.enumerable||!1,c.configurable=!0,"value"in c&&(c.writable=!0),Object.defineProperty(a,c.key,c)}return function(b,c,d){return c&&a(b.prototype,c),d&&a(b,d),b}}();function _classCallCheck(a,b){if(!(a instanceof b))throw new TypeError("Cannot call a class as a function");}
var TaboolaFeedScrollService=function(){function a(){_classCallCheck(this,a),this.scrolledTaboolaFeeds={},this.scrolledTaboolaFeedTracked=!1,this.trackTaboolaFeedScroll=this.trackTaboolaFeedScroll.bind(this),lazyLoadService.selfDestruct=!1,lazyLoadService.addScrollChangeListener(this.handleScrollDirectionChange.bind(this))}return _createClass(a,[{key:"trackTaboolaFeedScroll",value:function(a,b){var c=this,d=b.direction,e=function(){if(!c.scrolledTaboolaFeedTracked)trb.track({hitType:"event",eventType:"taboolaFeedImpression"}),
c.scrolledTaboolaFeedTracked=!0};"complete"===document.readyState?e(a):(!this.queuedItemObj&&DOMHelpers2.delegateEvent("readystatechange",function(){e(c.queuedItemObj)}),this.queuedItemObj=a),this.scrolledTaboolaFeeds[a.id]=a}},{key:"handleScrollDirectionChange",value:function(){var a=this.scrolledTaboolaFeeds;this.scrolledTaboolaFeeds=lazyLoadService.removePendingObjectsOfType("taboola"),Object.assign(lazyLoadService.pendingObjects,a)}},{key:"taboolaFeedShouldLoad",value:function(a,b){var c=b.direction,
d=a.getBoundingClientRect();return 0<=d.top&&d.top<=window.innerHeight}}]),a}();</script> <script async src="/pb/resources/gdist/91591ceea4c96329b023/balnews/balnews-metrics91591ceea4c96329b023.js?v=224"></script> <script async src="/pb/resources/gdist/91591ceea4c96329b023/balnews/balnews-lib91591ceea4c96329b023.js?v=224"></script> <script async src="/pb/resources/gdist/91591ceea4c96329b023/balnews/balnews-index91591ceea4c96329b023.js?v=224"></script><script>(function(){trb.data.ads.options={ptype:"s",iab:"",site:"trb."+trb.data.page.siteName,slug:"sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200504-y7erqozqynfgjot47n3axky2je",cid:"Y7ERQOZQYNFGJOT47N3AXKY2JE",at:"taxonomyTags",kw:"burrow,rookie,season,luck,akers,game,fantasy,williams,college,round,pick,receiver,ceh,edwards-helaire,team,yards,yard,nfl,Burrow,draft,opportunity,lsu,talent,sean,bengals",tg:"Football",design:"arc",nopulse:"true"}})();</script><script>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</script><script>trb.run.push(function(){i$("mediamanager")});(location.hash+location.search).indexOf("disable-autoplay")==-1&&trb.run.push(function(){i$.element.trigger(document.documentElement,"multimedia_autoplay")});</script><script>trb.data.page.ads.options.apfv="true";trb.data.page.snt={showWrapper:true,wrapperTitle:"TODAY'S TOP GAMBLING VIDEOS"};</script><script>trb.data.page.ads.options.apv="true";trb.data.page.snt={showWrapper:true,wrapperTitle:"TODAY'S TOP GAMBLING VIDEOS"};</script> 
  <script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"true","rua.upre":"false","rua.cpre":"true","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-73d28cd6-5895-4b95-ab62-5b86832217c4","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false"}]);</script>
  <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="9QU6Z-7BNQ8-E9TNM-DEQNV-AB6DG",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,o,_,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",_=document.getElementsByTagName("script")[0],_.parentNode.insertBefore(r,_);try{o=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",o=r.contentWindow.document}o.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"9QU6Z-7BNQ8-E9TNM-DEQNV-AB6DG",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},o.write("<bo"+'dy onload="document._l();">'),o.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e="true"=="true"?1:0,t="",n="nml5ubaxgizvaxvqjnoq-f-cf9726a57-clientnsv4-s.akamaihd.net",i={"ak.v":"27","ak.cp":"819098","ak.ai":parseInt("514477",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"","ak.rid":"32ca6b17","ak.r":31945,"ak.a2":e,"ak.m":"f","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":54226,"ak.gh":"23.50.51.76","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1588611933","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==KgNx5qcnIxEOKdmQH3cg3ABEByoAXZWwzKVGdAnUFaaZfbeQ/dZm9q5DqzEwnaSfKjNxFQA7wf0zD0hyt12HXsGue7PBNXw0LSHTAc4bJ2SkdN/lcgA8a6RgErgqSR6n6Vbj/amfa8FwesYrfk1x2hdyzG4fe9cCKlmAl711VEBZOzg2+aEoW4SPEgSZFMFjAvDLFI+A06zRzAQoLdJWCJIwH6tDHN++SWPtetD9kmH1NIUKriYFs7oXty+3serhQqoPM/8aKrE4Kf7iorOtX+q1i81Hy5EHN3L/Bm47c2ZDxdr348iTnhQCDCUh+/kuh3uvGXM+nEI0EGmNCtlL2FtMJfBrWPGotcrrljjgcgS+STxN860MWc7wZMDpktsNGEMcyPZm3LcZLBDi2sys4GvNSVPC0fatJYs23pwuBuo=","ak.pv":"33"};if(""!==t)i["ak.ruds"]=t;var o={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))i["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(i)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:i,akDNSPreFetchDomain:n,init:function(){if(!o.i){var a=BOOMR.subscribe;a("before_beacon",o.av,null,null),a("onbeacon",o.rv,null,null),o.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head> <body lang="en-US"> <svg style="display: none;"> <symbol id="angle-left" viewBox="0 0 11 32"><path d="M11.2 9.7q0 .2-.2.4l-7 7 7 7q.2.2.2.4t-.2.4l-.9.9q-.2.2-.4.2t-.4-.2L1 17.5q-.2-.2-.2-.4t.2-.4l8.3-8.3q.2-.2.4-.2t.4.2l.9.9q.2.2.2.4z"/></symbol><symbol id="angle-right" viewBox="0 0 11 32"><path d="M10.6 17.1q0 .2-.2.4l-8.3 8.3q-.2.2-.4.2t-.4-.2l-.9-.9q-.2-.2-.2-.4t.2-.4l7-7-7-7q-.2-.2-.2-.4t.2-.4l.9-.9q.2-.2.4-.2t.4.2l8.3 8.3q.2.2.2.4z"/></symbol><symbol id="camera" viewBox="0 0 34 32"><path d="M17.1 12q2.1 0 3.6 1.5t1.5 3.6-1.5 3.6-3.6 1.5-3.6-1.5-1.5-3.6 1.5-3.6 3.6-1.5zm12.6-7.4q1.9 0 3.2 1.3t1.3 3.2v16q0 1.9-1.3 3.2t-3.2 1.3H4.6q-1.9 0-3.2-1.3T.1 25.1v-16q0-1.9 1.3-3.2t3.2-1.3h4l.9-2.4q.3-.9 1.2-1.5t1.8-.6h9.1q.9 0 1.8.6t1.2 1.5l.9 2.4h4zM17.1 25.1q3.3 0 5.7-2.3t2.3-5.7-2.3-5.7-5.7-2.3-5.7 2.3-2.3 5.7 2.3 5.7 5.7 2.3z"/></symbol><symbol id="circle-o-notch" viewBox="0 0 32 32"><path d="M31.4 16q0 3.1-1.2 6t-3.3 4.9-4.9 3.3-6 1.2-6-1.2-4.9-3.3T1.8 22 .6 16q0-3.8 1.7-7.1T7 3.4 13.7.7v4.1q-3.9.8-6.5 3.9T4.6 16q0 2.3.9 4.4T7.9 24t3.6 2.4 4.4.9 4.4-.9 3.6-2.4 2.4-3.6.9-4.4q0-4.1-2.6-7.2t-6.5-3.9V.8q3.7.6 6.7 2.7T29.5 9t1.7 7.1z"/></symbol><symbol id="close" viewBox="0 0 25 32"><path d="M23.18 23.61q0 .71-.5 1.21l-2.43 2.43q-.5.5-1.21.5t-1.21-.5L12.58 22l-5.25 5.25q-.5.5-1.21.5t-1.21-.5l-2.43-2.43q-.5-.5-.5-1.21t.5-1.21l5.25-5.25-5.25-5.25q-.5-.5-.5-1.21t.5-1.21l2.43-2.43q.5-.5 1.21-.5t1.21.5l5.25 5.25 5.25-5.25q.5-.5 1.21-.5t1.21.5l2.43 2.43q.5.5.5 1.21t-.5 1.21l-5.25 5.25 5.25 5.25q.5.5.5 1.21z"/></symbol><symbol id="close-sticky" viewBox="0 0 32 32"><path d="M14.6 16L3.6 4.9l1.3-1.4L16 14.6 27.1 3.5l1.3 1.4-11 11.1 11 11.1-1.3 1.4L16 17.4 4.9 28.5l-1.3-1.4z"/></symbol><symbol id="exclamation" viewBox="0 0 11 32"><path d="M9.1 22.3v4q0 .5-.3.8t-.8.3H3.4q-.5 0-.8-.3t-.3-.8v-4q0-.5.3-.8t.8-.3H8q.5 0 .8.3t.3.8zm.6-18.9l-.5 13.7q0 .5-.4.8t-.8.3H3.4q-.5 0-.8-.3t-.4-.8L1.7 3.4q0-.5.3-.8t.8-.3h5.7q.5 0 .8.3t.3.8z"/></symbol><symbol id="exclamation-triangle" viewBox="0 0 32 32"><path d="M18.3 24.6v-3.4q0-.2-.2-.4t-.4-.2h-3.4q-.2 0-.4.2t-.2.4v3.4q0 .3.2.4t.4.2h3.4q.2 0 .4-.2t.2-.4zm0-6.7l.3-8.2q0-.2-.2-.3-.2-.2-.4-.2h-3.9q-.2 0-.4.2-.2.1-.2.4l.3 8.2q0 .2.2.3t.4.1h3.3q.3 0 .4-.1t.2-.3zM18 1.2l13.7 25.1q.6 1.1 0 2.3-.3.5-.8.8t-1.1.3H2.4q-.6 0-1.1-.3t-.8-.8q-.7-1.1 0-2.2L14.2 1.3q.3-.6.8-.9t1.2-.3 1.2.3.8.9z"/></symbol><symbol id="facebook-square" viewBox="0 0 32 32"><path d="M22.3 2.3q2.1 0 3.6 1.5t1.5 3.6v17.1q0 2.1-1.5 3.6t-3.6 1.5h-3.4V19h3.6l.5-4.1h-4.1v-2.6q0-1 .4-1.5t1.6-.5h2.2V6.6q-1.1-.2-3.2-.2-2.4 0-3.9 1.4t-1.5 4v3.1h-3.6V19h3.6v10.6H5q-2.1 0-3.6-1.5t-1.5-3.6V7.4q0-2.1 1.5-3.6T5 2.3h17.1z"/></symbol><symbol id="instagram" viewBox="0 0 32 32"><path d="M18.3 16q0-1.9-1.3-3.2t-3.2-1.3-3.2 1.3T9.3 16t1.3 3.2 3.2 1.3 3.2-1.3 1.3-3.2zm2.5 0q0 2.9-2.1 5t-5 2.1-5-2.1-2.1-5 2.1-5 5-2.1 5 2.1 2.1 5zm1.9-7.3q0 .7-.5 1.2t-1.2.5-1.2-.5-.5-1.2.5-1.2T21 7t1.2.5.5 1.2zm-9-3.9h-3.3q-.6 0-1.7.1t-1.8.2-1.3.3q-.9.4-1.6 1T3 8q-.2.5-.3 1.3t-.2 1.8-.1 1.7 0 1.9 0 1.4 0 1.4 0 1.9.1 1.7.2 1.8.3 1.3q.4.9 1 1.6t1.6 1q.5.2 1.3.3t1.8.2 1.7.1 1.9 0 1.4 0 1.4 0 1.9 0 1.7-.1 1.8-.2 1.3-.3q.9-.4 1.6-1t1-1.6q.2-.5.3-1.3t.2-1.8.1-1.7 0-1.9 0-1.4 0-1.4 0-1.9-.1-1.7-.2-1.8-.3-1.3q-.4-.9-1-1.6t-1.6-1q-.5-.2-1.3-.3t-1.8-.2-1.7-.1-1.9 0-1.4 0zM27.4 16q0 4.1-.1 5.7-.2 3.7-2.2 5.8t-5.7 2.2q-1.6.1-5.7.1T8 29.7q-3.7-.2-5.7-2.2T.1 21.8Q0 20.2 0 16.1t.1-5.7q.2-3.7 2.2-5.7t5.8-2.2q1.6-.1 5.7-.1t5.7.1q3.7.2 5.8 2.2t2.2 5.8q.1 1.6.1 5.7z"/></symbol><symbol id="search" viewBox="0 0 30 32"><path d="M20.6 14.9q0-3.3-2.3-5.7t-5.7-2.3-5.7 2.3-2.3 5.7 2.3 5.7 5.7 2.3 5.7-2.3 2.3-5.7zm9.1 14.8q0 .9-.7 1.6t-1.6.7q-1 0-1.6-.7l-6.1-6.1q-3.2 2.2-7.1 2.2-2.6 0-4.9-1t-4-2.7-2.7-4-1-4.9 1-4.9 2.7-4 4-2.7 4.9-1 4.9 1 4 2.7 2.7 4 1 4.9q0 3.9-2.2 7.1l6.1 6.1q.7.7.7 1.6z"/></symbol><symbol id="sections-bars" viewBox="0 0 448 512"><path d="M16 132h416c8.837 0 16-7.163 16-16V76c0-8.837-7.163-16-16-16H16C7.163 60 0 67.163 0 76v40c0 8.837 7.163 16 16 16zm0 160h416c8.837 0 16-7.163 16-16v-40c0-8.837-7.163-16-16-16H16c-8.837 0-16 7.163-16 16v40c0 8.837 7.163 16 16 16zm0 160h416c8.837 0 16-7.163 16-16v-40c0-8.837-7.163-16-16-16H16c-8.837 0-16 7.163-16 16v40c0 8.837 7.163 16 16 16z"/></symbol><symbol id="share" viewBox="0 0 32 32"><path d="M32 11.4q0 .5-.3.8l-9.1 9.1q-.3.3-.8.3t-.8-.3-.3-.8v-4.6h-4q-1.7 0-3.1.1t-2.7.4-2.4.8-1.9 1.2-1.4 1.8-.9 2.5-.3 3.2q0 1 .1 2.2v.9q0 .3-.2.4t-.4.2q-.3 0-.5-.3l-.2-.4q-.1-.2-.2-.5t-.2-.4Q.1 22.9.1 19.9q0-3.6.9-5.9 2.9-7.2 15.6-7.2h4V2.2q0-.5.3-.8t.8-.3.8.3l9.1 9.1q.3.3.3.8z"/></symbol><symbol id="sign-in" viewBox="0 0 32 32"><path d="M21.1 16q0 .5-.3.8l-9.7 9.7q-.3.3-.8.3t-.8-.3-.3-.8v-5.1h-8q-.5 0-.8-.3t-.3-.8v-6.9q0-.5.3-.8t.8-.3h8V6.4q0-.5.3-.8t.8-.3.8.3l9.7 9.7q.3.3.3.8zm6.3-6.3v12.6q0 2.1-1.5 3.6t-3.6 1.5h-5.7q-.2 0-.4-.2t-.2-.4v-.4-.5q0-.2.1-.4t.2-.3.4-.1h5.7q1.2 0 2-.8t.8-2V9.7q0-1.2-.8-2t-2-.8h-5.8l-.2-.1-.1-.1-.1-.2v-.2-.4-.5q0-.2.1-.4t.2-.3.4-.1h5.7q2.1 0 3.6 1.5t1.5 3.6z"/></symbol><symbol id="twitter" viewBox="0 0 30 32"><path d="M28.9 7.3q-1.2 1.8-2.9 3v.8q0 2.3-.7 4.6t-2.1 4.4-3.3 3.8-4.6 2.6-5.8 1q-4.8 0-8.9-2.6.6.1 1.4.1 4 0 7.2-2.5-1.9 0-3.4-1.2t-2-2.8q.6.1 1.1.1.8 0 1.5-.2-2-.4-3.3-2t-1.3-3.7v-.1q1.2.7 2.6.7-1.2-.8-1.9-2.1t-.7-2.7q0-1.6.8-2.9 2.2 2.7 5.3 4.3t6.6 1.8q-.1-.7-.1-1.3 0-2.4 1.7-4.1t4.1-1.7q2.5 0 4.2 1.8Q26.3 6 28.1 5q-.7 2.1-2.5 3.2 1.7-.2 3.3-.9z"/></symbol><symbol id="user-circle-o" viewBox="0 0 32 32"><path d="M16 0q3.3 0 6.2 1.3t5.1 3.4 3.4 5.1T32 16q0 3.2-1.3 6.2t-3.4 5.1-5.1 3.4T16 32t-6.2-1.3-5.1-3.4-3.4-5.1T0 16t1.3-6.2 3.4-5.1 5.1-3.4T16 0zm11.1 24.1q2.7-3.7 2.7-8.1 0-2.8-1.1-5.3t-2.9-4.4-4.4-2.9-5.3-1.1-5.3 1.1-4.4 2.9-2.9 4.4T2.4 16q0 4.5 2.7 8.1 1.2-5.8 5.5-5.8 2.3 2.3 5.6 2.3t5.6-2.3q4.3 0 5.5 5.8zm-4.2-11.5q0-2.8-2-4.8t-4.8-2-4.8 2-2 4.8 2 4.8 4.8 2 4.8-2 2-4.8z"/></symbol><symbol id="vimeo" viewBox="0 0 32 32"><path d="M30.5 9.3q-.2 4.2-5.9 11.6-5.9 7.7-10 7.7-2.5 0-4.3-4.7-.8-2.9-2.4-8.6-1.3-4.7-2.8-4.7-.3 0-2.3 1.4l-1.4-1.7q.4-.4 1.9-1.7t2.3-2.1Q8.4 4 9.9 3.9q1.7-.2 2.7 1T14 8.5q.8 5.1 1.2 6.7 1 4.4 2.1 4.4.9 0 2.8-2.9 1.8-2.9 1.9-4.4.2-2.5-1.9-2.5-1 0-2.2.5 2.1-7 8.2-6.8 4.5.1 4.2 5.8z"/></symbol><symbol id="youtube" viewBox="0 0 32 32"><path d="M17.3 22.2V26q0 1.2-.7 1.2-.4 0-.8-.4v-5.4q.4-.4.8-.4.7 0 .7 1.2zm6.1 0v.8h-1.6v-.8q0-1.2.8-1.2t.8 1.2zM6.1 18.3H8v-1.7H2.4v1.7h1.9v10.2h1.8V18.3zm5.2 10.2h1.6v-8.8h-1.6v6.8q-.5.8-1 .8-.3 0-.4-.4v-7.1H8.3v7q0 .9.1 1.3.2.7 1 .7.9 0 1.8-1.1v1zm7.6-2.6v-3.5q0-1.3-.2-1.8-.3-1-1.3-1-.9 0-1.7 1v-3.9h-1.6v11.8h1.6v-.9q.8 1 1.7 1 1 0 1.3-1 .2-.5.2-1.8zm6.1-.2v-.2h-1.6v1.1q-.1.6-.7.6-.8 0-.8-1.2v-1.6h3.2v-1.8q0-1.4-.5-2.1-.7-.9-1.9-.9t-1.9.9q-.5.7-.5 2.1v3.1q0 1.4.5 2.1.7.9 1.9.9 1.3 0 1.9-.9.3-.5.4-1v-1zM14.1 9.4V5.7q0-1.2-.8-1.2t-.8 1.2v3.8q0 1.3.8 1.3t.8-1.2zm12.8 13.4q0 4.2-.5 6.3-.2 1.1-1 1.8t-1.8.8q-3.3.4-9.9.4t-9.9-.4q-1-.1-1.8-.8t-1-1.8q-.5-2-.5-6.2t.5-6.2q.3-1.1 1-1.8t1.8-.8q3.3-.4 9.9-.4t9.9.4q1 .1 1.8.8t1 1.8q.5 2 .5 6.3zM9.1 0h1.8L8.7 7.1v4.8H6.9V7.1q-.2-1.3-1.1-3.8Q5.1 1.5 4.6 0h1.9l1.3 4.7zm6.6 5.9V9q0 1.4-.5 2.1-.7.9-1.9.9t-1.9-.9q-.5-.7-.5-2.1V5.9q0-1.4.5-2.1.7-.9 1.9-.9t1.9.9q.5.7.5 2.1zm6-2.8V12h-1.6v-1q-.9 1.1-1.8 1.1-.8 0-1.1-.7-.1-.4-.1-1.3v-7h1.6V10.3q.1.4.4.4.5 0 1-.8V3.1h1.6z"/></symbol> </svg> <div id="pb-root" class="collapsed-nav"><a class="skip-link" href="#skip-to-content">Skip to content</a> <header id="app-bar-sticky" class="sticky high-z-index"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-app-bar" data-pb-name="App Bar" data-pb-curated="curated" data-pb-id="main-app-bar" id="frKhQf12SrP0Xr"> <div id="app-bar" class="app-bar crd crd-dark crd-acc crd-shdo" data-reg-role="app-bar"> <div class="justify-space-between flex-container-row relative app-bar-inner container"> <div class="flex flex-md flex-container-row"> <div data-role="tray" data-tray="topics"> <button id="app-bar-topics-button" name="topicsMenu" class="tag tag-solid tag-accent app-button align-center justify-center flex-container-row" data-role="open-tray" data-tray="topics" aria-expanded="false" aria-controls="sections-menu"> <svg class="icon-light icon-margin-auto icon-18-27" focusable="false"> <use xlink:href="#sections-bars"/> </svg> <span class="spaced spaced-sm spaced-left hddn-mble">Sections</span> </button> <div class="tray-arrow-container invble relative"> <div class="tray-arrow absolute"> <svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 292.362 292.362" fill="#616668" height="22px" width="22px" focusable="false"> xml:space="preserve"> <path d="M286.935,197.286L159.028,69.379c-3.613-3.617-7.895-5.424-12.847-5.424s-9.233,1.807-12.85,5.424L5.424,197.286 C1.807,200.9,0,205.184,0,210.132s1.807,9.233,5.424,12.847c3.621,3.617,7.902,5.428,12.85,5.428h255.813 c4.949,0,9.233-1.811,12.848-5.428c3.613-3.613,5.427-7.898,5.427-12.847S290.548,200.9,286.935,197.286z"/> </svg> </div> </div> <nav class="tray tray-left invble absolute" aria-labelledby="app-bar-topics-button" id="sections-menu"> <div class="topics-tray tray-contents crd"> <div data-role="close-submenu" class="tray-contents-inner" tabindex="-1"> <div class="crd--cnt search-container"> <div class="mobile-search-wrapper hddn-dktp"> <form class="form-inline flex-container-row" method="GET" action="/search/" target="_top" autocomplete="off" role="search"> <input class="search-bar" title="Type search term here" name="" type="text" placeholder="Search for a topic" data-autocomplete="false" data-autocomplete-target="app-bar-topics-autocomplete-results" autocomplete="off"/> <button aria-label="submit" type="submit" class="svg-c search-button button-icon button-rounded button-lg button-accent"> <svg class="icon-light icon-17-18" aria-hidden="true" focusable="false"> <use xlink:href="#search"/> </svg> </button> </form> <div id="app-bar-topics-autocomplete-results"></div> </div> </div> <div class="placeholder-topics-list"> </div> <div class="tray-contents-util"> <hr/> <div data-reg-role="trial"></div> </div> </div> </div> </nav> </div> <div data-role="tray" data-tray="search"> <button id="app-bar-search-button" name="searchMenu" class="tag tag-solid tag-accent app-button spaced spaced-left spaced-md align-center justify-center flex-container-row hddn-mble hddn-tbl" data-role="open-tray" data-tray="search" aria-expanded="false" aria-controls="appbar-searchbox"> <svg class="icon-light icon-margin-auto icon-16-17" aria-hidden="true" focusable="false"> <use xlink:href="#search"/> </svg> <span class="hddn-tbl spaced spaced-sm spaced-left">Search</span> </button> <div class="tray-arrow-container relative spaced spaced-left spaced-md hddn-mble hddn-tbl"> <div class="tray-arrow absolute"> <svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 292.362 292.362" fill="#616668" height="22px" width="22px" focusable="false"> xml:space="preserve"> <path d="M286.935,197.286L159.028,69.379c-3.613-3.617-7.895-5.424-12.847-5.424s-9.233,1.807-12.85,5.424L5.424,197.286 C1.807,200.9,0,205.184,0,210.132s1.807,9.233,5.424,12.847c3.621,3.617,7.902,5.428,12.85,5.428h255.813 c4.949,0,9.233-1.811,12.848-5.428c3.613-3.613,5.427-7.898,5.427-12.847S290.548,200.9,286.935,197.286z"/> </svg> </div> </div> <nav class="tray tray-left invble absolute hddn-mble hddn-tbl" role="presentation" id="appbar-searchbox"> <div class="search-tray tray-contents search crd"> <div class="tray-contents-inner"> <div class="crd--cnt"> <form class="form-inline flex-container-row" method="GET" action="/search/" target="_top" autocomplete="off" role="search"> <input class="search-bar" title="Type search term here" name="" type="text" placeholder="Search for a topic" data-autocomplete="false" data-autocomplete-target="app-bar-search-autocomplete-results" autocomplete="off"/> <button aria-label="submit" type="submit" class="svg-c search-button button-icon button-rounded button-lg button-accent"> <svg class="icon-light icon-17-18" aria-hidden="true" focusable="false"> <use xlink:href="#search"/> </svg> </button> </form> <div id="app-bar-search-autocomplete-results"></div> </div> </div> </div> </nav> </div> </div> <div class="flex flex-container-row align-items-center justify-center-md justify-center-desktop flex-fill"> <a aria-label="Baltimore Sun Logo - Visit Homepage" href="/?#nt=mastheadnavbar" class="logo-container "> <img class="logo logo-full logo-no-background logo-transparent logo-md" alt="The Baltimore Sun" src="/pb/resources/images/balnews_icons/app-bar-logo.svg?v=224"/> </a> <div class="flex-container-row align-items-center hddn-mble hddn-tbl hddn-mble-permanent links-container hddn flex-fill" role="navigation" aria-label="Site"> <ul class="app-bar-menu no-overflow flex-wrap flex-container-row list-unstyled justify-center flex-fill"> <li class="links spaced spaced-right spaced-left spaced-sm "> <a class="uppercase text-color-light mobile app-bar-text" href="https://digitaledition.baltimoresun.com">Enewspaper</a> </li><li class="links spaced spaced-right spaced-left spaced-sm "> <a class="uppercase text-color-light mobile app-bar-text" href="https://www.baltimoresun.com/latest/#nt=tertiarynavbar">Latest</a> </li><li class="links spaced spaced-right spaced-left spaced-sm "> <a class="uppercase text-color-light mobile app-bar-text" href="https://www.baltimoresun.com/sports/#nt=tertiarynavbar">Sports</a> </li><li class="links spaced spaced-right spaced-left spaced-sm hddn-mble hddn-tbl"> <a class="uppercase text-color-light mobile app-bar-text" href="https://www.legacy.com/obituaries/baltimoresun/">Obituaries</a> </li><li class="links spaced spaced-right spaced-left spaced-sm hddn-mble hddn-tbl"> <a class="uppercase text-color-light mobile app-bar-text" href="https://www.baltimoresun.com/weather/#nt=tertiarynavbar">Weather</a> </li><li class="links spaced spaced-right spaced-left spaced-sm hddn-mble hddn-tbl"> <a class="uppercase text-color-light mobile app-bar-text" href="https://www.baltimoresun.com/opinion/#nt=tertiarynavbar">Opinion</a> </li><li class="links spaced spaced-right spaced-left spaced-sm hddn-mble hddn-tbl"> <a class="uppercase text-color-light mobile app-bar-text" href="https://casmp.adperfect.com/?hostname=classifieds.baltimoresun.com">Advertising</a> </li></ul> </div> </div> <div class="flex flex-container-row"> <div class="login-subscribe"> <div class="dss-login-subscribe bar-dss" data-reg-role="base"></div> </div> </div> </div> </div> </div> <div data-reg-role="prompt"></div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-screamer" data-pb-name="Screamer" data-pb-curated="curated" data-pb-id="unnamed-feature" id="f0V4fN82SrP0Xr"> <div id="screamer-wrapper" class="screamer-wrapper" data-href="/pb/api/v2/render/feature?name=breaking-news-bar&uri=/zzz-breaking-news/&wrapper=false"> </div> </div> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-list-nav-ticker" data-pb-name="Feed-driven Nav Ticker" data-pb-curated="automated" data-pb-id="unnamed-feature" id="fA3piV12SrP0Xr"> <div data-role="slider" class=" slider hover-nav-buttons hddn-mble"> <div class="button-container button-container-left hddn-mble hddn-tbl"> <button name="slide-left" aria-label="Previous set of articles" data-role="slider-button" data-direction="left" class="svg-c button-slider button-slider-js hddn button-icon button-dark button-xl"> <svg class="icon-10-27" focusable="false"> <use xlink:href="#angle-left"/> </svg> </button> </div> <ul data-role="slider-container" class="slider-container clln clln-htal flex-container-row clln-inset clln-hv "> <li class="ticker-brd-lf"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-generic-card" data-pb-name="Generic Card" data-pb-curated="curated" data-pb-id="unnamed-feature" id=""> <div class="crd crd-inl-md "> <div class="crd--cnt flex-container-row justify-space-between align-items-start "> <a class="flex-reverse" href="/coronavirus/bs-md-coronavirus-monday-20200504-yijycxipxzbznkpnpap2jesmtm-story.html#nt=tertiarynavbar&nt=ticker" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="crd-mda-ri image-xxs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="Rate of coronavirus hospitalizations, intensive cases flat in Maryland, deaths increase 10%" data-src="https://www.baltimoresun.com/resizer/BUBC-3iHZqnUgaHfEEmIB5Vu6wA=/64x64/top/www.baltimoresun.com/resizer/VDsk3Rgxd4Ph7Buov6P_c8K5lxQ=/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/G3R3LAMWWBEKLB64MKATQFSJNU.jpg" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"/> </div> </figure> </a> <a class="tcate-ln-3 truncate-line no-overflow relative story-recommender spaced spaced-top spaced-sm crd--tle" href="/coronavirus/bs-md-coronavirus-monday-20200504-yijycxipxzbznkpnpap2jesmtm-story.html#nt=tertiarynavbar&nt=ticker"> Rate of coronavirus hospitalizations, intensive cases flat in Maryland, deaths increase 10% </a> <div class="preview-text"></div> </div> </div> </div> </li> <li class="ticker-brd-lf"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-generic-card" data-pb-name="Generic Card" data-pb-curated="curated" data-pb-id="unnamed-feature" id=""> <div class="crd crd-inl-md "> <div class="crd--cnt flex-container-row justify-space-between align-items-start "> <a class="flex-reverse" href="/sports/ravens/bs-sp-don-shula-colts-obit-20200504-nyhqgmtfizaejljik44kk5jvuy-story.html#nt=tertiarynavbar&nt=ticker" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="crd-mda-ri image-xxs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="Hall of Fame coach Don Shula, who won NFL championship with Baltimore Colts, dies" data-src="https://www.baltimoresun.com/resizer/MH2lRi1VxbXRRPyTAwnNtYCzMug=/64x64/top/www.baltimoresun.com/resizer/93BNAEtdpn6wXFWtwHKi1nfs78k=/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/VKGQSAYBGZFMNOCTKNXIAVCEVU.jpg" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"/> </div> </figure> </a> <a class="tcate-ln-3 truncate-line no-overflow relative story-recommender spaced spaced-top spaced-sm crd--tle" href="/sports/ravens/bs-sp-don-shula-colts-obit-20200504-nyhqgmtfizaejljik44kk5jvuy-story.html#nt=tertiarynavbar&nt=ticker"> Hall of Fame coach Don Shula, who won NFL championship with Baltimore Colts, dies </a> <div class="preview-text"></div> </div> </div> </div> </li> <li class="ticker-brd-lf"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-generic-card" data-pb-name="Generic Card" data-pb-curated="curated" data-pb-id="unnamed-feature" id=""> <div class="crd crd-inl-md "> <div class="crd--cnt flex-container-row justify-space-between align-items-start "> <a class="flex-reverse" href="/coronavirus/bs-md-coronavirus-cases-statewide-maryland-20200317-rk7n7qam4fd33ka7zvrxv3xybe-htmlstory.html#nt=tertiarynavbar&nt=ticker" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="crd-mda-ri image-xxs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="Here are the known cases of coronavirus in Maryland [GRAPHICS]" data-src="https://www.baltimoresun.com/resizer/tmvQHJybhosDowKcpDPQrDIySOA=/64x64/top/www.baltimoresun.com/resizer/KQMy9DcjD279B9_p63ydbwbCmx4=/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/ZEIXQERJ7FBS7GEQTZR2DII5SY.jpg" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"/> </div> </figure> </a> <a class="tcate-ln-3 truncate-line no-overflow relative story-recommender spaced spaced-top spaced-sm crd--tle" href="/coronavirus/bs-md-coronavirus-cases-statewide-maryland-20200317-rk7n7qam4fd33ka7zvrxv3xybe-htmlstory.html#nt=tertiarynavbar&nt=ticker"> Here are the known cases of coronavirus in Maryland [GRAPHICS] </a> <div class="preview-text"></div> </div> </div> </div> </li> <li class="ticker-brd-lf"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-generic-card" data-pb-name="Generic Card" data-pb-curated="curated" data-pb-id="unnamed-feature" id=""> <div class="crd crd-inl-md "> <div class="crd--cnt flex-container-row justify-space-between align-items-start "> <a class="flex-reverse" href="/coronavirus/bs-md-umd-coronavirus-20200502-p4u2eobscbb7phim4ieaolmupy-story.html#nt=tertiarynavbar&nt=ticker" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="crd-mda-ri image-xxs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="A University of Maryland student’s father died of COVID-19. A professor encouraged her to keep up with coursework." data-src="https://www.baltimoresun.com/resizer/gvc-TKCmQ_WDg5SsVaOuCwPJ01A=/64x64/top/www.baltimoresun.com/resizer/ZJtde8D_RSHBSbgXg_3xGMPybCs=/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/J2IGW3GNBJGB3MMQFVMGNZJXV4.JPG" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"/> </div> </figure> </a> <a class="tcate-ln-3 truncate-line no-overflow relative story-recommender spaced spaced-top spaced-sm crd--tle" href="/coronavirus/bs-md-umd-coronavirus-20200502-p4u2eobscbb7phim4ieaolmupy-story.html#nt=tertiarynavbar&nt=ticker"> A University of Maryland student’s father died of COVID-19. A professor encouraged her to keep up with coursework. </a> <div class="preview-text"></div> </div> </div> </div> </li> <li class="ticker-brd-lf"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-generic-card" data-pb-name="Generic Card" data-pb-curated="curated" data-pb-id="unnamed-feature" id=""> <div class="crd crd-inl-md "> <div class="crd--cnt flex-container-row justify-space-between align-items-start "> <a class="flex-reverse" href="/coronavirus/bs-md-daily-coronavirus-updates-20200319-k3zo35wudvhehb5yklyjv6jjem-story.html#nt=tertiarynavbar&nt=ticker" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="crd-mda-ri image-xxs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="Maryland coronavirus updates for May 4: Maryland small businesses approved for $3.2 billion in loans; Carroll County photographer focuses on nature" data-src="https://www.baltimoresun.com/resizer/AX18n3rPNgfdc5xjtgqw73w8XNY=/64x64/top/www.baltimoresun.com/resizer/Fw4o6QLA_M9D0GKRxCX0wTAzJbo=/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/7TWMDJD2SBFQJKNKXWR5LUQKDM.jpg" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"/> </div> </figure> </a> <a class="tcate-ln-3 truncate-line no-overflow relative story-recommender spaced spaced-top spaced-sm crd--tle" href="/coronavirus/bs-md-daily-coronavirus-updates-20200319-k3zo35wudvhehb5yklyjv6jjem-story.html#nt=tertiarynavbar&nt=ticker"> Maryland coronavirus updates for May 4: Maryland small businesses approved for $3.2 billion in loans; Carroll County photographer focuses on nature </a> <div class="preview-text"></div> </div> </div> </div> </li> <li class="ticker-brd-lf"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-generic-card" data-pb-name="Generic Card" data-pb-curated="curated" data-pb-id="unnamed-feature" id=""> <div class="crd crd-inl-md "> <div class="crd--cnt flex-container-row justify-space-between align-items-start "> <a class="flex-reverse" href="/news/nation-world/ct-nw-nyt-murder-hornet-20200502-r6lypy5mdjcell65qjl3zavks4-story.html#nt=tertiarynavbar&nt=ticker" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="crd-mda-ri image-xxs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="Tracking the ‘murder hornet’: A deadly pest has reached North America" data-src="https://www.baltimoresun.com/resizer/7-UDUoVCMB4W4UerWdZE4Cl3BE4=/64x64/top/www.baltimoresun.com/resizer/6lq9kkd24WOI1kJPsMjAMNAeDu8=/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/MHHFKIERA5A7VOP3BCMY4AJRGY.jpg" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"/> </div> </figure> </a> <a class="tcate-ln-3 truncate-line no-overflow relative story-recommender spaced spaced-top spaced-sm crd--tle" href="/news/nation-world/ct-nw-nyt-murder-hornet-20200502-r6lypy5mdjcell65qjl3zavks4-story.html#nt=tertiarynavbar&nt=ticker"> Tracking the ‘murder hornet’: A deadly pest has reached North America </a> <div class="preview-text"></div> </div> </div> </div> </li> <li class="ticker-brd-lf"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-generic-card" data-pb-name="Generic Card" data-pb-curated="curated" data-pb-id="unnamed-feature" id=""> <div class="crd crd-inl-md "> <div class="crd--cnt flex-container-row justify-space-between align-items-start "> <a class="flex-reverse" href="/coronavirus/bs-md-hogan-reopening-plan-20200424-p5uyo4ec3jbilea4gitudvzgv4-story.html#nt=tertiarynavbar&nt=ticker" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="crd-mda-ri image-xxs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="Maryland Gov. Hogan outlines three-stage plan to reopen businesses when coronavirus abates" data-src="https://www.baltimoresun.com/resizer/A1McZ3iRo0ryi-bso-6kspmlO9U=/64x64/top/www.baltimoresun.com/resizer/2Lv1ivUoYUn_wDoWUqFnZDmitZg=/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/4RN4VIN2LNDFFEBYLZQYGFDLHE.jpg" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"/> </div> </figure> </a> <a class="tcate-ln-3 truncate-line no-overflow relative story-recommender spaced spaced-top spaced-sm crd--tle" href="/coronavirus/bs-md-hogan-reopening-plan-20200424-p5uyo4ec3jbilea4gitudvzgv4-story.html#nt=tertiarynavbar&nt=ticker"> Maryland Gov. Hogan outlines three-stage plan to reopen businesses when coronavirus abates </a> <div class="preview-text"></div> </div> </div> </div> </li> <li class="ticker-brd-lf"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-generic-card" data-pb-name="Generic Card" data-pb-curated="curated" data-pb-id="unnamed-feature" id=""> <div class="crd crd-inl-md "> <div class="crd--cnt flex-container-row justify-space-between align-items-start "> <a class="flex-reverse" href="/coronavirus/bs-md-baltimore-police-mayor-young-rent-20200504-puimmf63zveonhkpstakmy6dfy-story.html#nt=tertiarynavbar&nt=ticker" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="crd-mda-ri image-xxs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="Baltimore Police investigate after Young billboard is vandalized to push for no rent during pandemic, criticize police" data-src="https://www.baltimoresun.com/resizer/Yr4_ZPJu9ZmfNMeRSLA2B3rglPM=/64x64/top/www.baltimoresun.com/resizer/Ft2xo-lQTxCijqvZYf-IZ9b3ouI=/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/UKMIOJF27RHQHEFMXFKCZGS3RY.jpg" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"/> </div> </figure> </a> <a class="tcate-ln-3 truncate-line no-overflow relative story-recommender spaced spaced-top spaced-sm crd--tle" href="/coronavirus/bs-md-baltimore-police-mayor-young-rent-20200504-puimmf63zveonhkpstakmy6dfy-story.html#nt=tertiarynavbar&nt=ticker"> Baltimore Police investigate after Young billboard is vandalized to push for no rent during pandemic, criticize police </a> <div class="preview-text"></div> </div> </div> </div> </li> <li class="ticker-brd-lf"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-generic-card" data-pb-name="Generic Card" data-pb-curated="curated" data-pb-id="unnamed-feature" id=""> <div class="crd crd-inl-md "> <div class="crd--cnt flex-container-row justify-space-between align-items-start "> <a class="flex-reverse" href="/sports/terps/bs-sp-maryland-football-tyler-mabry-seattle-seahawks-20200504-e3nuqns2mrg7rf6ng4faaa7jtq-story.html#nt=tertiarynavbar&nt=ticker" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="crd-mda-ri image-xxs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="Maryland tight end Tyler Mabry’s patience rewarded with undrafted rookie deal with Seahawks" data-src="https://www.baltimoresun.com/resizer/FBgdzh-FMl1uSTkTonhzVOOMsfs=/64x64/top/www.baltimoresun.com/resizer/cuKUWiV57EXM_EbonsePK8lbs_E=/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/QC4S5PVQKJAWXA445JNBT6X3NA.jpg" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"/> </div> </figure> </a> <a class="tcate-ln-3 truncate-line no-overflow relative story-recommender spaced spaced-top spaced-sm crd--tle" href="/sports/terps/bs-sp-maryland-football-tyler-mabry-seattle-seahawks-20200504-e3nuqns2mrg7rf6ng4faaa7jtq-story.html#nt=tertiarynavbar&nt=ticker"> Maryland tight end Tyler Mabry’s patience rewarded with undrafted rookie deal with Seahawks </a> <div class="preview-text"></div> </div> </div> </div> </li> <li class="ticker-brd-lf"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-generic-card" data-pb-name="Generic Card" data-pb-curated="curated" data-pb-id="unnamed-feature" id=""> <div class="crd crd-inl-md "> <div class="crd--cnt flex-container-row justify-space-between align-items-start "> <a class="flex-reverse" href="/coronavirus/bs-md-may-3-coronavirus-update-20200503-l7rkvpxejnfifif7hhlw5gtmry-story.html#nt=tertiarynavbar&nt=ticker" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="crd-mda-ri image-xxs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="Maryland reports 989 newly confirmed coronavirus cases and 26 deaths related to COVID-19" data-src="https://www.baltimoresun.com/resizer/Iy8_1CuAiEu0OYW0SV1HiUHAqZw=/64x64/top/www.baltimoresun.com/resizer/MAOJre6bdvZ61tw0KtetRDp0TdE=/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/Q3ICIR462BERHHJU3VFPVEXIPI.jpg" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"/> </div> </figure> </a> <a class="tcate-ln-3 truncate-line no-overflow relative story-recommender spaced spaced-top spaced-sm crd--tle" href="/coronavirus/bs-md-may-3-coronavirus-update-20200503-l7rkvpxejnfifif7hhlw5gtmry-story.html#nt=tertiarynavbar&nt=ticker"> Maryland reports 989 newly confirmed coronavirus cases and 26 deaths related to COVID-19 </a> <div class="preview-text"></div> </div> </div> </div> </li> <li class="ticker-brd-lf"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-generic-card" data-pb-name="Generic Card" data-pb-curated="curated" data-pb-id="unnamed-feature" id=""> <div class="crd crd-inl-md "> <div class="crd--cnt flex-container-row justify-space-between align-items-start "> <a class="flex-reverse" href="/coronavirus/bs-md-tom-inglesby-20200503-20200503-mzi7o52hsfe65ovuumaawzap5u-story.html#nt=tertiarynavbar&nt=ticker" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="crd-mda-ri image-xxs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="As states ease restrictions, Hopkins expert forecasts ‘waves’ of new coronavirus cases through summer and fall" data-src="https://www.baltimoresun.com/resizer/sTlcf7OcvNKGNOP8NQKCwxqdbSk=/64x64/top/www.baltimoresun.com/resizer/6xF6YY9ayXzILcIzSNBuk71eroE=/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/6SV6KOY3RRCUFKC4MS2HWHA5AE.JPG" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"/> </div> </figure> </a> <a class="tcate-ln-3 truncate-line no-overflow relative story-recommender spaced spaced-top spaced-sm crd--tle" href="/coronavirus/bs-md-tom-inglesby-20200503-20200503-mzi7o52hsfe65ovuumaawzap5u-story.html#nt=tertiarynavbar&nt=ticker"> As states ease restrictions, Hopkins expert forecasts ‘waves’ of new coronavirus cases through summer and fall </a> <div class="preview-text"></div> </div> </div> </div> </li> <li class="ticker-brd-lf"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-generic-card" data-pb-name="Generic Card" data-pb-curated="curated" data-pb-id="unnamed-feature" id=""> <div class="crd crd-inl-md "> <div class="crd--cnt flex-container-row justify-space-between align-items-start "> <a class="flex-reverse" href="/maryland/carroll/news/crime/cc-taneytown-murder-jail-transfer-20200504-yeje6gabwjbtre7wx4wntqiqai-story.html#nt=tertiarynavbar&nt=ticker" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="crd-mda-ri image-xxs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="In murder case, Westminster woman jailed in West Virginia; Westminster man opposing extradition, still in Virginia" data-src="https://www.baltimoresun.com/resizer/dy9gB2R-Dxhk7pxGaB36zbxoJnc=/64x64/top/www.baltimoresun.com/resizer/Znzl6zze6HIq6hZj5wkSvUlZ1Hs=/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/CMD3THMPOJEF7JJOGDQKZJTGRI.jpg" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"/> </div> </figure> </a> <a class="tcate-ln-3 truncate-line no-overflow relative story-recommender spaced spaced-top spaced-sm crd--tle" href="/maryland/carroll/news/crime/cc-taneytown-murder-jail-transfer-20200504-yeje6gabwjbtre7wx4wntqiqai-story.html#nt=tertiarynavbar&nt=ticker"> In murder case, Westminster woman jailed in West Virginia; Westminster man opposing extradition, still in Virginia </a> <div class="preview-text"></div> </div> </div> </div> </li> <li class="ticker-brd-lf"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-generic-card" data-pb-name="Generic Card" data-pb-curated="curated" data-pb-id="unnamed-feature" id=""> <div class="crd crd-inl-md "> <div class="crd--cnt flex-container-row justify-space-between align-items-start "> <a class="flex-reverse" href="/sports/analysis/preston/bs-sp-ravens-preston-all-time-team-offense-coach-20200504-roqpnjunrrcj7fydlnx2qd6eri-story.html#nt=tertiarynavbar&nt=ticker" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="crd-mda-ri image-xxs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="Ravens’ All-Time team: The best offensive players and coach in franchise history | COMMENTARY" data-src="https://www.baltimoresun.com/resizer/YKvQHiseeEzv0gx9uKiMrkGk7gs=/64x64/top/www.baltimoresun.com/resizer/jo1HU2CiRQEMFOQ0hxn-pNxSGzQ=/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/2RS5OT444BHPFEDDOD3A2VEWIA.jpg" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"/> </div> </figure> </a> <a class="tcate-ln-3 truncate-line no-overflow relative story-recommender spaced spaced-top spaced-sm crd--tle" href="/sports/analysis/preston/bs-sp-ravens-preston-all-time-team-offense-coach-20200504-roqpnjunrrcj7fydlnx2qd6eri-story.html#nt=tertiarynavbar&nt=ticker"> Ravens’ All-Time team: The best offensive players and coach in franchise history | COMMENTARY </a> <div class="preview-text"></div> </div> </div> </div> </li> <li class="ticker-brd-lf"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-generic-card" data-pb-name="Generic Card" data-pb-curated="curated" data-pb-id="unnamed-feature" id=""> <div class="crd crd-inl-md "> <div class="crd--cnt flex-container-row justify-space-between align-items-start "> <a class="flex-reverse" href="/coronavirus/bs-hs-coronavirus-in-maryland-20200306-uapaoyvwvbeitijchgvordohwe-story.html#nt=tertiarynavbar&nt=ticker" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="crd-mda-ri image-xxs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="Coronavirus in Maryland: Everything you need to know" data-src="https://www.baltimoresun.com/resizer/Er5CJUBdRM5P7oWz8Nz7vkpTcXo=/64x64/top/www.baltimoresun.com/resizer/gI8MBXnK0UO1OUCNOKKw2xScujM=/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/LDTJ4H4HD5BCXDKG5SKIBXHX6A.JPG" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"/> </div> </figure> </a> <a class="tcate-ln-3 truncate-line no-overflow relative story-recommender spaced spaced-top spaced-sm crd--tle" href="/coronavirus/bs-hs-coronavirus-in-maryland-20200306-uapaoyvwvbeitijchgvordohwe-story.html#nt=tertiarynavbar&nt=ticker"> Coronavirus in Maryland: Everything you need to know </a> <div class="preview-text"></div> </div> </div> </div> </li> <li class="ticker-brd-lf"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-generic-card" data-pb-name="Generic Card" data-pb-curated="curated" data-pb-id="unnamed-feature" id=""> <div class="crd crd-inl-md "> <div class="crd--cnt flex-container-row justify-space-between align-items-start "> <a class="flex-reverse" href="/coronavirus/bs-md-cox-hogan-federal-court-20200503-6vyfomqmdfg3bpw2peiuje6g4a-story.html#nt=tertiarynavbar&nt=ticker" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="crd-mda-ri image-xxs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="State delegates, pastors and businesses file lawsuit against Hogan seeking to end coronavirus restrictions" data-src="https://www.baltimoresun.com/resizer/OrnGylLJndcgywPiJyHVgSBzbls=/64x64/top/www.baltimoresun.com/resizer/ZOXkDAFqaI32QChDfB_sVdIYqcQ=/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/HH7W6XJALBD6REMQSNC5UQY5MM.JPG" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"/> </div> </figure> </a> <a class="tcate-ln-3 truncate-line no-overflow relative story-recommender spaced spaced-top spaced-sm crd--tle" href="/coronavirus/bs-md-cox-hogan-federal-court-20200503-6vyfomqmdfg3bpw2peiuje6g4a-story.html#nt=tertiarynavbar&nt=ticker"> State delegates, pastors and businesses file lawsuit against Hogan seeking to end coronavirus restrictions </a> <div class="preview-text"></div> </div> </div> </div> </li> </ul> <div class="button-container button-container-right hddn-mble hddn-tbl"> <button name="slide-right" aria-label="Next set of articles" data-role="slider-button" data-direction="right" class="arrow-container button-slider button-slider-js hddn button-icon button-dark button-xl"> <svg class="icon-10-27" focusable="false"> <use xlink:href="#angle-right"/> </svg> </button> </div> </div> </div> <div class="pb-container"> </div> </header> <div data-role="close-tray" subscriptions-section="content"> <article class="container padded-container" data-ad-container="reskin"> <main class="artcl--m"> <div tabindex="-1" id="skip-to-content"></div> <header id="top" class="top artcl--h full-columns"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-dfp" data-pb-name="DFP Ad" data-pb-curated="curated" data-pb-id="article-masthead-leaderboard" id="fnxdCM12SrP0Xr"> <div class="pb-ad pb-ad-prod ad-320x50 relative&#32;sticky-leaderboard" data-ad-sticky-timer-rate="2"> <div class="ad-caption-text align-center uppercase">Advertisement</div> <div class="trb_st_cl " tabindex="0" aria-label="Close Ad" role="button" aria-pressed="false"> <svg class="closeSticky" focusable="false"> <use xlink:href="#close-sticky"/> </svg> </div> <div id="hp_777" class="hddn" data-optimera-measure="trb_ad_1280x220/970x250/970x90/728x90/320x100/320x50_1_/gambling/sns-actnet-rookie-fantasy-football-" data-ad-type="leaderboard"data-ad-sticky> </div> </div> <script>
    (function() {
    
      
        //FetchBids for all ads
        if (true && window.apstag && true && window.headertag) {
          let params = {
            id: 'hp_777',
            slotName: '/4011/trb.baltimoresun/hp',
            includeInA9: true,
            includeInIndexExchange: true
          }
          const dimensions = !' [[[1280, 220], [970, 250], [970, 90], [728, 90]], [[1280, 220], [728, 90]], [[1280, 220], [320, 100], [320, 50]]] '.length ? null : JSON.parse(' [[[1280, 220], [970, 250], [970, 90], [728, 90]], [[1280, 220], [728, 90]], [[1280, 220], [320, 100], [320, 50]]] '),
                sizemapDimensions = !'[[1280, 0], [800, 0], [0, 0]]'.length ? null : JSON.parse('[[1280, 0], [800, 0], [0, 0]]')
          if (sizemapDimensions) {
            const mapping = DFPHelpers.prepareSizeMaps(dimensions, sizemapDimensions).mapping
            headerBiddingAdVendorHelpers.fetchBids(DFPHelpers.parseSizeMappings(mapping), params)
          } else {
            headerBiddingAdVendorHelpers.fetchBids(dimensions, params)
          }
        }

        
          if (trb.data.ads.optimera) {
            if (!window.oPageUnload) {
              oAv.push("trb_ad_1280x220/970x250/970x90/728x90/320x100/320x50_1_/gambling/sns-actnet-rookie-fantasy-football-");
              oVa["trb_ad_1280x220/970x250/970x90/728x90/320x100/320x50_1_/gambling/sns-actnet-rookie-fantasy-football-"] = ["NULL"];
            } else {
              oPageUnload('trb_ad_1280x220/970x250/970x90/728x90/320x100/320x50_1_/gambling/sns-actnet-rookie-fantasy-football-', true);
            }
          }
        
      
      // Validation to fix ORCA-896 issue
      
        function loadAd() {
            dfpService.appendAd({
                id: 'hp_777',
                optimeraId: 'trb_ad_1280x220/970x250/970x90/728x90/320x100/320x50_1_/gambling/sns-actnet-rookie-fantasy-football-',
                adType: 'leaderboard',
                slotName: '/4011/trb.baltimoresun/hp',
                displayMobile: true,
                displayDesktop: true,
                isOOP: false,
                is5x1: false,
                dimensionsString: ' [[[1280, 220], [970, 250], [970, 90], [728, 90]], [[1280, 220], [728, 90]], [[1280, 220], [320, 100], [320, 50]]] ',
                sizemapString: '[[1280, 0], [800, 0], [0, 0]]',
                sizemapRefresh: 'true',
                refreshOnPhotoChange: false,
                adRefreshInterval: 0,
                includeInA9: true,
                includeInIndexExchange: true,
                loadImmediately: true,
                adLite: 'nonstick'
            }, false, true)
        }

        loadAd();
      

    })()
  </script> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-header" data-pb-name="Article Header" data-pb-curated="curated" data-pb-id="standard-detail-article-right-rail-header" id="fsJ8b012SrP0Xr"> <div class="crd card "> <div class="crd--cnt card-content align-left "> <ul class="tag-list-wrapper list-unstyled flex-container-row align-left " role="presentation"> <li> <a class="tag tag-solid tag-first" href="https://www.baltimoresun.com/gambling/#nt=taxonomy-article"> Gambling </a> </li> </ul> <h1 class="spaced spaced-xl spaced-top spaced-bottom abdp-headline">Who will be the top rookie in fantasy? Experts debate</h1> </div> <div class="crd--ft card-footer flex-container-row article-header align-items-center justify-space-between "> <div class="byline-container flex-container-row align-items-center"> <div class="byline-image-container hddn-mble spaced spaced-right spaced-sm"> </div> <div class="byline-timestamp-container"> <div class="byline-wrapper"> <span class="byline byline-article">By <span class="uppercase">Action Network Staff, The Action Network</span> </span> </div> <span class="spaced spaced-right spaced-md hddn-mble"></span> <div class="timestamp-wrapper flex-container-row align-items-center flex-mobile-column "> <div class="align-center"> <span class="timestamp timestamp-article">Tribune Content Agency</span> <span class="timestamp spaced spaced-sm spaced-left spaced-right hddn-mble" aria-hidden="true">|</span> </div> <div> <span class="timestamp timestamp-article "> May 04, 2020 </span> <span class="timestamp spaced spaced-sm spaced-left spaced-right hddn-tbl" aria-hidden="true">|</span> <span class="timestamp timestamp-article hddn-tbl "> 12:10 PM </span> </div> </div> </div> </div> <span class="sharebar "> <button class="svg-c button button-icon button-icon-hover-accent " aria-label="share on twitter" name="twitter" onclick="window.open( 'https://twitter.com/intent/tweet?text=Who+will+be+the+top+rookie+in+fantasy%3F+Experts+debate&url=https%3A%2F%2Fwww.baltimoresun.com%2Fgambling%2Fsns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200504-y7erqozqynfgjot47n3axky2je-story.html', 'share_popup', 'height=500,width=650' ); return false;" role="button" data-arctrack="socialShareTwtr" data-referrer="story" target="_blank" rel="noopener noreferrer"> <svg class="icon-margin-auto button-icon-inset-accent icon-16-17" focusable="false"> <use xlink:href="#twitter"/> </svg> </button> <button class="svg-c button button-icon button-icon-hover-accent " name="facebook" aria-label="share on facebook" onclick="window.open( 'https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.baltimoresun.com%2Fgambling%2Fsns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200504-y7erqozqynfgjot47n3axky2je-story.html&title=Who+will+be+the+top+rookie+in+fantasy%3F+Experts+debate', 'share_popup', 'height=500,width=650' ); return false;" data-arctrack="socialShareFb" data-referrer="story" data-href="https://www.baltimoresun.com/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200504-y7erqozqynfgjot47n3axky2je-story.html" target="_blank" rel="noopener noreferrer"> <svg class="icon-margin-auto button-icon-inset-accent icon-16-17" focusable="false"> <use xlink:href="#facebook-square"/> </svg> </button> <a class="svg-c button button-icon button-icon-hover-accent " href="mailto:?subject=Who%20will%20be%20the%20top%20rookie%20in%20fantasy%3F%20Experts%20debate&body=https%3A%2F%2Fwww.baltimoresun.com%2Fgambling%2Fsns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200504-y7erqozqynfgjot47n3axky2je-story.html" role="button" aria-label="share story via email" data-arctrack="socialShareEmail" data-referrer="story" rel="noopener noreferrer"> <svg class="icon-margin-auto button-icon-inset-accent icon-16-17" focusable="false"> <use xlink:href="#share"/> </svg> </a> </span> </div> </div> </div> <div class="pb-container"> </div> </header> <section id="left" class="artcl--sect-tmpl left guttered width-100"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-list-recommender" data-pb-name="Recommender" data-pb-curated="automated" id="fre7Mj22SrP0Xr"> <script>document.getElementById("fre7Mj22SrP0Xr").className+="mobile"=="mobile"?" hddn-dktp":"mobile"=="desktop"?" hddn-mble hddn-tbl":"";</script> <script>document.getElementById("fre7Mj22SrP0Xr").className+=" hidden-desktop";</script> </div> <div class="pb-container"> <div class="wrapper clearfix col spaced spaced-top spaced-none col-desktop-6 col-tablet-6 col-mobile-6 pb-feature pb-layout-item pb-f-global-newsletter-promo" data-pb-name="Newsletter Promo Card" data-pb-curated="curated" id="f0AUjgU2SrP0Xr"> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-utilities-lead-art" data-pb-name="Lead Art" data-pb-curated="curated" data-pb-id="unnamed-feature" id="foX28922SrP0Xr"> <div class="crd card-captioned "> <div class="crd--cnt"> <aside class="trb_em" data-content-embedlocation="Content level lead art" data-content-size="leadart" data-content-type="video" data-role="mediamanager_container"> <div class="trb_em_m"> <div itemprop="video" class="trb_em_v" data-role="mediamanager_item" data-state="thumbnail" data-content-subtype="embeddedvideo_stn" data-float-position="right"> <a class="trb_em_v_a" data-role="mediamanager_autoplay mediamanager_trigger" data-video-attributes='{"floating": "true","player_id": "Dj7gRv6L","cid": "4643","type": "s2n","topVideo": "false"}' href="#" onclick="return false;"></a> </div> </div> </aside> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-body" data-pb-name="Article Body (Elements)" data-pb-curated="curated" data-pb-id="unnamed-feature" id="fQcrqN12SrP0Xr"> <div class=""> </div> <div class=" clln clln-crd overflow-auto cs__ctn__border-bottom"> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p data-page="1" data-item-type="depthscroll" data-item-id="depth_scroll_top" data-item-number="top"> The 2020 NFL Draft class was loaded with talent at wide receiver, but our experts don’t think a WR will be the top rookie in fantasy football this season.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> Our trio of rankers Chris Raybon, Matthew Freedman and Sean Koerner make the case for the first-year players they think will emerge as the most productive in fantasy. (Spoiler: They all made different picks.)</p> </div></div> <div class="mobile-dfp inline-ad hddn-dktp" data-inline-ad-count="1"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-dfp" data-pb-name="DFP Ad" data-pb-curated="curated" data-pb-id="unnamed-feature" id="fArjGo1l5Xw2Yr"> <div class="pb-ad pb-ad-prod ad-300x250 hddn-dktp relativehddn-dktp"> <div class="ad-caption-text align-center uppercase">Advertisement</div> <div id="hp_984" class="hddn" data-optimera-measure="trb_ad_300x250_inlineAdCube_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-"> </div> </div> <script>
    (function() {
    
      
        //FetchBids for all ads
        if (true && window.apstag && true && window.headertag) {
          let params = {
            id: 'hp_984',
            slotName: '/4011/trb.baltimoresun/hp',
            includeInA9: true,
            includeInIndexExchange: true
          }
          const dimensions = !'[[300, 250]]'.length ? null : JSON.parse('[[300, 250]]'),
                sizemapDimensions = !''.length ? null : JSON.parse('')
          if (sizemapDimensions) {
            const mapping = DFPHelpers.prepareSizeMaps(dimensions, sizemapDimensions).mapping
            headerBiddingAdVendorHelpers.fetchBids(DFPHelpers.parseSizeMappings(mapping), params)
          } else {
            headerBiddingAdVendorHelpers.fetchBids(dimensions, params)
          }
        }

        
          if (trb.data.ads.optimera) {
            if (!window.oPageUnload) {
              oAv.push("trb_ad_300x250_inlineAdCube_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-");
              oVa["trb_ad_300x250_inlineAdCube_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-"] = ["NULL"];
            } else {
              oPageUnload('trb_ad_300x250_inlineAdCube_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-', true);
            }
          }
        
      
      // Validation to fix ORCA-896 issue
      
        function loadAd() {
            dfpService.appendAd({
                id: 'hp_984',
                optimeraId: 'trb_ad_300x250_inlineAdCube_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-',
                adType: 'inlineAdCube',
                slotName: '/4011/trb.baltimoresun/hp',
                displayMobile: true,
                displayDesktop: false,
                isOOP: false,
                is5x1: false,
                dimensionsString: '[[300, 250]]',
                sizemapString: '',
                sizemapRefresh: 'false',
                refreshOnPhotoChange: false,
                adRefreshInterval: 0,
                includeInA9: true,
                includeInIndexExchange: true,
                loadImmediately: true,
                adLite: 'hide'
            }, false, true)
        }

        loadAd();
      

    })()
  </script> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> <b>Sean Koerner: Clyde Edwards-Helaire, RB, Chiefs</b></p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> Entering the draft, Edwards-Helaire was a potential top 3-5 rookie in fantasy. However, after being the only RB selected in the Round 1, he is the clear No. 1 rookie to draft this year.</p> </div></div> <div class="desktop-nativo mobile-yieldmo inline-ad " data-inline-ad-count="2"> <span class="hddn-dktp"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-ads-yieldmo" data-pb-name="Yieldmo Ad" data-pb-curated="curated" data-pb-id="unnamed-feature" id=""> <div id="ym_1885667251538527982"></div> <script>window.serviceCallbacks.push(function(){if(DeviceDetection.any()&&UrlParams.isVendorEnabled("yieldmo"))(((window.trb||(trb={})).ads||(trb.ads={})).adLiteCheck||(trb.ads.adLiteCheck=[])).push(function(adLite){var el=document.getElementById("ym_1885667251538527982");if(adLite){el.closest(".inline-ad").style.display="none";return}if(false)lazyLoadService.addPendingObject({id:"ym_1885667251538527982",el:el,load:function(){YieldmoService.load({id:"ym_1885667251538527982",el:el})}});else YieldmoService.load({id:"ym_1885667251538527982",
el:el})})});</script> </div></span> <span class="hddn-mble"><div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-nativo" data-pb-name="Nativo Ad" data-pb-curated="curated" data-pb-id="unnamed-feature" id="f0KOjUsC5Xw2Yr"> <div id="9684" class="trb_ar_nt"> </div> </div></span> <span class="hddn-mble hidden-tablet"><div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-nativo" data-pb-name="Nativo Ad" data-pb-curated="curated" data-pb-id="unnamed-feature" id="f0KOjUsC5Xw2Yr"> <div id="9684" class="trb_ar_nt"> </div> </div></span> </div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> Being selected in the first round is usually a clear sign that a team intends to use a running back heavily right out of the gate. Here’s a breakdown of how many touches, on average, rookie RBs have seen since 2010 by round:</p> </div></div> <div data-type="list" class="crd clln--it"> <div class=" crd--cnt "> <div class=""> <ul class="element-ul"> <li> <b>Round 1:</b> 228</li> <li> <b>Round 2:</b> 145</li> <li> <b>Round 3:</b> 124</li> <li> <b>Round 4:</b> 82</li> <li> <b>Round 5:</b> 61</li> <li> <b>Round 6:</b> 38</li> <li> <b>Round 7:</b> 24</li> </ul> </div> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> As you can see, there is reason to believe the Chiefs will use their first-round back heavily this season.</p> </div></div> <div class="inline-ad hidden-desktop"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-nativo" data-pb-name="Nativo Ad" data-pb-curated="curated" data-pb-id="unnamed-feature" id="f0DJ0HxT5Xw2Yr"> <div id="12807" class="trb_ar_nt_m" data-ad-lite="true"> </div> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> I have received this question a few times already: “But what about Damien Williams?” But every single rookie RB has landed on a team with built-in competition for snaps, so I do not think the presence of Williams is enough to draft any other rookie RB ahead of CEH.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> The Dolphins selected Williams as an undrafted free agent in 2014, and he was nothing more than a change-of-pace back in Miami. He became a borderline RB1 (when healthy) in his first two seasons in Kansas City, but that says more about the Chiefs offense than it does about Williams.</p> </div></div> <div class="mobile-nativo inline-ad hddn-dktp" data-inline-ad-count="3"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-nativo" data-pb-name="Nativo Ad" data-pb-curated="curated" data-pb-id="unnamed-feature" id="fX6Q0j2a6Xw2Yr"> <div id="9327" class="trb_ar_nt_m"> </div> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> CEH is a way more talented back and should get every chance to dominate touches this year.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> The Chiefs offense is so explosive that even if this does become a RB committee, CEH won’t need 20 or more touches a game to put up RB2 value — that’s what makes his 2020 floor/ceiling combo both the highest of this class.</p> </div></div> <div class="inline-ad hidden-desktop"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-dfp" data-pb-name="DFP Ad" data-pb-curated="curated" data-pb-id="unnamed-feature" id="fLx9f22s6Xw2Yr"> <div class="pb-ad pb-ad-prod ad-300x250 hddn-dktp relativehddn-dktp"> <div class="ad-caption-text align-center uppercase">Advertisement</div> <div id="hp_1125" class="hddn" data-optimera-measure="trb_ad_300x250_adLiteCube_3_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-he"> </div> </div> <script>
    (function() {
    
      
        //FetchBids for all ads
        if (true && window.apstag && true && window.headertag) {
          let params = {
            id: 'hp_1125',
            slotName: '/4011/trb.baltimoresun/hp',
            includeInA9: true,
            includeInIndexExchange: true
          }
          const dimensions = !'[[300, 250]]'.length ? null : JSON.parse('[[300, 250]]'),
                sizemapDimensions = !''.length ? null : JSON.parse('')
          if (sizemapDimensions) {
            const mapping = DFPHelpers.prepareSizeMaps(dimensions, sizemapDimensions).mapping
            headerBiddingAdVendorHelpers.fetchBids(DFPHelpers.parseSizeMappings(mapping), params)
          } else {
            headerBiddingAdVendorHelpers.fetchBids(dimensions, params)
          }
        }

        
          if (trb.data.ads.optimera) {
            if (!window.oPageUnload) {
              oAv.push("trb_ad_300x250_adLiteCube_3_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-he");
              oVa["trb_ad_300x250_adLiteCube_3_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-he"] = ["NULL"];
            } else {
              oPageUnload('trb_ad_300x250_adLiteCube_3_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-he', true);
            }
          }
        
      
      // Validation to fix ORCA-896 issue
      
        function loadAd() {
            dfpService.appendAd({
                id: 'hp_1125',
                optimeraId: 'trb_ad_300x250_adLiteCube_3_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-he',
                adType: 'adLiteCube',
                slotName: '/4011/trb.baltimoresun/hp',
                displayMobile: true,
                displayDesktop: false,
                isOOP: false,
                is5x1: false,
                dimensionsString: '[[300, 250]]',
                sizemapString: '',
                sizemapRefresh: 'false',
                refreshOnPhotoChange: false,
                adRefreshInterval: 0,
                includeInA9: true,
                includeInIndexExchange: true,
                loadImmediately: false,
                adLite: 'show'
            }, false, false)
        }

        loadAd();
      

    })()
  </script> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> The sky is the limit for Edwards-Helaire.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> <b>Matthew Freedman: Cam Akers, RB, Rams</b></p> </div></div> <div class="mobile-yieldmo inline-ad hddn-dktp" data-inline-ad-count="4"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-ads-yieldmo" data-pb-name="Yieldmo Ad" data-pb-curated="curated" data-pb-id="unnamed-feature" id=""> <div id="ym_1000072"></div> <script>window.serviceCallbacks.push(function(){if(DeviceDetection.any()&&UrlParams.isVendorEnabled("yieldmo"))(((window.trb||(trb={})).ads||(trb.ads={})).adLiteCheck||(trb.ads.adLiteCheck=[])).push(function(adLite){var el=document.getElementById("ym_1000072");if(adLite){el.closest(".inline-ad").style.display="none";return}if(true)lazyLoadService.addPendingObject({id:"ym_1000072",el:el,load:function(){YieldmoService.load({id:"ym_1000072",el:el})}});else YieldmoService.load({id:"ym_1000072",el:el})})});</script> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> If we’re talking about the best rookie in fantasy for dynasty, my pick is Clyde Edwards-Helaire. As Sean points out, CEH has a lot going for him as early as this year.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> But if you’re talking about the best rookie for fantasy in 2020, then I’m going with Cam Akers.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> First of all, I think he’s talented.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> If you check out the RotoViz Combine Explorer, you’ll see that a high percentage of the 20 players to whom Akers is most physically comparable as a prospect — 50% of the backs, in fact — averaged at least 10 fantasy points per game in their first three seasons. Included in that list are Hall-of-Famers LaDainian Tomlinson and Marshawn Lynch and 2019 top-three pick Miles Sanders.</p> </div></div> <div class="mobile-dfp inline-ad hddn-dktp" data-inline-ad-count="5"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-dfp" data-pb-name="DFP Ad" data-pb-curated="curated" data-pb-id="unnamed-feature" id="f056KJKX6Xw2Yr"> <div class="pb-ad pb-ad-prod ad-300x250 hddn-dktp relativehddn-dktp"> <div class="ad-caption-text align-center uppercase">Advertisement</div> <div id="hp_1154" class="hddn" data-optimera-measure="trb_ad_300x250_inlineAdCube_4_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-"> </div> </div> <script>
    (function() {
    
      
        //FetchBids for all ads
        if (true && window.apstag && true && window.headertag) {
          let params = {
            id: 'hp_1154',
            slotName: '/4011/trb.baltimoresun/hp',
            includeInA9: true,
            includeInIndexExchange: true
          }
          const dimensions = !'[[300, 250]]'.length ? null : JSON.parse('[[300, 250]]'),
                sizemapDimensions = !''.length ? null : JSON.parse('')
          if (sizemapDimensions) {
            const mapping = DFPHelpers.prepareSizeMaps(dimensions, sizemapDimensions).mapping
            headerBiddingAdVendorHelpers.fetchBids(DFPHelpers.parseSizeMappings(mapping), params)
          } else {
            headerBiddingAdVendorHelpers.fetchBids(dimensions, params)
          }
        }

        
          if (trb.data.ads.optimera) {
            if (!window.oPageUnload) {
              oAv.push("trb_ad_300x250_inlineAdCube_4_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-");
              oVa["trb_ad_300x250_inlineAdCube_4_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-"] = ["NULL"];
            } else {
              oPageUnload('trb_ad_300x250_inlineAdCube_4_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-', true);
            }
          }
        
      
      // Validation to fix ORCA-896 issue
      
        function loadAd() {
            dfpService.appendAd({
                id: 'hp_1154',
                optimeraId: 'trb_ad_300x250_inlineAdCube_4_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-',
                adType: 'inlineAdCube',
                slotName: '/4011/trb.baltimoresun/hp',
                displayMobile: true,
                displayDesktop: false,
                isOOP: false,
                is5x1: false,
                dimensionsString: '[[300, 250]]',
                sizemapString: '',
                sizemapRefresh: 'false',
                refreshOnPhotoChange: false,
                adRefreshInterval: 0,
                includeInA9: true,
                includeInIndexExchange: true,
                loadImmediately: false,
                adLite: 'hide'
            }, false, false)
        }

        loadAd();
      

    })()
  </script> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> And the RV Combine Explorer looks only at physical profile: It doesn’t even take into account Akers’ age, production, recruitment grade or draft position.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> Akers entered college as a top-five overall recruit and a five-star all-purpose championship-winning quarterback who passed for 3,128 yards and 31 touchdowns and rushed for 2,105 yards and 34 touchdowns as a high-school senior, and in his three years as a starting running back in college, he did nothing to suggest that the evaluation people had of him as a recruit was wrong or that he won’t be able to play in the NFL.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> In college, Akers ran behind the fourth-worst Power Five run-blocking unit (Pro Football Focus). That’s not good. Even so, he was productive.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> He never had a full-on in-your-face campaign, but in 2017 Akers broke Dalvin Cook’s FSU rushing record for a freshman, and in 2019 he returned to form after a down sophomore campaign.</p> </div></div> <div data-type="list" class="crd clln--it"> <div class=" crd--cnt "> <div class=""> <ul class="element-ul"> <li> 2017: 194-1,015-7 rushing, 16-116-1 receiving in 13 games</li> <li> 2018: 161-706-6 rushing, 23-145-2 receiving in 12 games</li> <li> 2019: 132-1,144-14 rushing, 30-225-4 receiving in 11 games</li> </ul> </div> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p data-item-type="depthscroll" data-item-id="depth_scroll_middle" data-item-number="middle"> And, in 2019, Akers averaged more than 100 yards rushing per game “while facing contact at or behind the line of scrimmage at the highest rate of any FBS back in the country” (per PFF).</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> Akers is big (5-foot-10 and 217 pounds), fast (4.47-second 40-yard dash), young (21 years old) and a Day 2 pick (2.52). There’s so much to like about him.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> Over the past 25 years, there have been six 21-year-old second- and third-round rookie running backs to play at 210-plus pounds and have multiple 1,000-yard seasons in college.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> Here’s how they’ve done in the NFL.</p> </div></div> <div data-type="list" class="crd clln--it"> <div class=" crd--cnt "> <div class=""> <ul class="element-ul"> <li> Ahman Green (1998, 3.76): Six 1,000-yard seasons</li> <li> Bernard Pierce (2012, 3.84): Nada</li> <li> Le’Veon Bell (2013, 2.48): Five 1,000-yard seasons</li> <li> Joe Mixon (2017, 2.48): Two 1,000-yard seasons</li> <li> Alexander Mattison (2019, 3.102): Waiting</li> </ul> </div> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> Akers might be Pierce 2.0, but I think its likelier that he’s a premium version of Green.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> So he’s talented. On top of that, he’s likely to have opportunity.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> With the departure of running back Todd Gurley, the Rams entered the draft with a league-high 216.5 vacated expected points at the position. In terms of opportunity, Akers might have landed in the best spot possible.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> The Rams will need to give the ball to someone in the backfield, and Akers is a prime candidate.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> The Rams have been a top-12 scoring team in each year of head coach Sean McVay’s tenure, and in Gurley’s two pre-2019 seasons with head coach Sean McVay — before he developed his stuck-in-molasses running style — he was an All-Pro producer.</p> </div></div> <div data-type="list" class="crd clln--it"> <div class=" crd--cnt "> <div class=""> <ul class="element-ul"> <li> 2017 (15 games): 279-1,305-13 rushing, 64-788-6 receiving on 87 targets</li> <li> 2018 (14 games): 256-1,251-17 rushing, 59-580-4 receiving on 81 targets</li> </ul> </div> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> Even if Akers isn’t a great receiver, he still seems likely to get a decent number of targets if he’s the lead back — and even though the Rams drafted Darrell Henderson last year with the No. 70 pick — it’s hard to imagine that Akers won’t dominate touches given his draft capital and overall talent.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> If the Rams had wanted to give the ball to Henderson, then they wouldn’t have drafted Akers. Starting in Week 1, Akers could get 15-plus touches per game, and I think that’s more than we can say for any of the other rookie backs.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> <b>Chris Raybon: Joe Burrow, QB, Bengals</b></p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> Burrow’s championship-winning season at LSU in 2019 was one for the ages: He set the all-time single-season record for TD passes (60) and passer rating (202.0). His 76.3% completion percentage stands second-best all-time; his 5,671 passing yards, third-best. And with the Bengals showing longtime starter Andy Dalton the door, Burrow is on track to start all 16 games.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> There have been five quarterbacks picked No. 1 overall in the past decade who have gone on to start all 16 games in Year 1, and four of the five have been starter-worthy in fantasy:</p> </div></div> <div data-type="list" class="crd clln--it"> <div class=" crd--cnt "> <div class=""> <ul class="element-ul"> <li> <b>Kyler Murray (2019):</b> QB8; 285.3 FP</li> <li> <b>Jameis Winston (2015):</b> QB13; 275.0 FP</li> <li> <b>Andrew Luck (2012): </b>QB10; 276.5 FP</li> <li> <b>Cam Newton (2011):</b> QB4; 323.5 FP</li> <li> <b>Sam Bradford (2010):</b> QB20; 194.8 FP</li> </ul> </div> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> Burrow doesn’t have wheels on the level of Newton or Murray, and thus is most reminiscent of Luck, who, ironically, represents the median outcome of that group with a QB10 finish in his rookie season. In fact, Burrow’s 27.4 yards 0.43 touchdowns per game rushing in his two years at LSU compare favorably to Luck’s numbers on the ground in his final two years at Stanford (23.2 yards, 0.19 TDs). And just as Luck inherited an aging All-Pro wide receiver in 34-year-old Reggie Wayne and a promising Day 2 pick in T.Y. Hilton, Burrow will get 32-year-old A.J. Green and second-round Clemson star, Tee Higgins.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> The rest of Burrow’s supporting cast at pass catcher is sneaky good.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p data-page="2"> Tyler Boyd has become one of the best slot receivers in the NFL, averaging 5.5 receptions per game over his past two seasons. John Ross, 2017 first-rounder, overcame a disastrous start to his career to average 18.1 yards per reception last season and has quietly registered a TD on a whopping 20.4% of his career catches (10-of-49). Even Auden Tate and Alex Erickson — the projected No. 5 and 6 wideouts — put up starter-quality production when called upon in 2019, combining for 10 games of 50-plus yards receiving.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> Out of the backfield, Joe Mixon and Giovani Bernard are plus pass-catchers, so Burrow’s backs and receivers are shaping up similarly to the arsenal he had with wideouts Ja’Marr Chase, Justin Jefferson, Terrace Marshall Jr. and Clyde Edwards-Helaire in Burrow’s record-setting season at LSU. Only four of Burrow’s 60 TD passes last season went to tight ends, so the underwhelming duo of C.J. Uzomah and Drew Sample shouldn’t be too much of a detriment (and Sample does have some upside as a 6-foot-4, 258-pound second-rounder entering Year 2).</p> </div></div> <div class="mobile-dfp inline-ad hddn-dktp" data-inline-ad-count="6"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-dfp" data-pb-name="DFP Ad" data-pb-curated="curated" data-pb-id="unnamed-feature" id="f026nepn7Xw2Yr"> <div class="pb-ad pb-ad-prod ad-300x250 hddn-dktp relativehddn-dktp"> <div class="ad-caption-text align-center uppercase">Advertisement</div> <div id="hp_982" class="hddn" data-optimera-measure="trb_ad_300x250_inlineAdCube_5_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-"> </div> </div> <script>
    (function() {
    
      
        //FetchBids for all ads
        if (true && window.apstag && true && window.headertag) {
          let params = {
            id: 'hp_982',
            slotName: '/4011/trb.baltimoresun/hp',
            includeInA9: true,
            includeInIndexExchange: true
          }
          const dimensions = !'[[300, 250]]'.length ? null : JSON.parse('[[300, 250]]'),
                sizemapDimensions = !''.length ? null : JSON.parse('')
          if (sizemapDimensions) {
            const mapping = DFPHelpers.prepareSizeMaps(dimensions, sizemapDimensions).mapping
            headerBiddingAdVendorHelpers.fetchBids(DFPHelpers.parseSizeMappings(mapping), params)
          } else {
            headerBiddingAdVendorHelpers.fetchBids(dimensions, params)
          }
        }

        
          if (trb.data.ads.optimera) {
            if (!window.oPageUnload) {
              oAv.push("trb_ad_300x250_inlineAdCube_5_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-");
              oVa["trb_ad_300x250_inlineAdCube_5_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-"] = ["NULL"];
            } else {
              oPageUnload('trb_ad_300x250_inlineAdCube_5_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-', true);
            }
          }
        
      
      // Validation to fix ORCA-896 issue
      
        function loadAd() {
            dfpService.appendAd({
                id: 'hp_982',
                optimeraId: 'trb_ad_300x250_inlineAdCube_5_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-',
                adType: 'inlineAdCube',
                slotName: '/4011/trb.baltimoresun/hp',
                displayMobile: true,
                displayDesktop: false,
                isOOP: false,
                is5x1: false,
                dimensionsString: '[[300, 250]]',
                sizemapString: '',
                sizemapRefresh: 'false',
                refreshOnPhotoChange: false,
                adRefreshInterval: 0,
                includeInA9: true,
                includeInIndexExchange: true,
                loadImmediately: false,
                adLite: 'hide'
            }, false, false)
        }

        loadAd();
      

    })()
  </script> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> The biggest concern for Burrow will be the Bengals’ offensive line that allowed 48 sacks, tied for ninth-most in the league. But even if he ends up taking his fair share of licks, he should make up for it with sheer volume: Head coach Zac Taylor dialed up the sixth-most pass attempts (616) even with Dalton and Ryan Finley behind center, and the Bengals defense projects to be below average after finishing 30th in Football Outsiders’ DVOA a year ago.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p class="stop-here"> Ultimately, what sets Burrow apart as my top rookie in fantasy is his opportunity relative to the top running backs such as Edwards-Helaire and Cam Akers and wide receivers such as Henry Ruggs III, Jerry Jeudy and CeeDee Lamb — none of whom project as a locked-in touch or target leader on their teams in the same way Burrow can be expected to take every dropback for the Bengals. And since Burrow will likely be drafted outside the top 12 quarterbacks, he has just as good of a chance as any of providing massive value relative to his average draft position.</p> </div></div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p> <i>Check out </i><a href="https://www.actionnetwork.com/?utm_source=tribune&amp;utm_medium=referral&amp;utm_campaign=tribune_topblurb"><i>The Action Network</i></a><i> for more expert sports betting information and to find the </i><a href="https://www.actionnetwork.com/online-sports-betting?utm_source=tribune&amp;utm_medium=referral&amp;utm_campaign=tribune_topblurb"><i>best online sportsbooks</i></a><i>.</i></p> </div></div> <div data-type="recommender" data-pb-id="in-body-recommender" class="crd clln--it hddn-dktp "> <div class="crd--cnt "> <div class="crd rcom--ctn flex-container-column align-items-stretch "> <div class="crd--hd flex-container-row align-items-center"> <h2 class="fte-hd">Latest Gambling</h2> </div> <div class="crd--cnt "> <ul class="list-unstyled clln clln-vtl clln-crd "> <li class="clln--it flex-container-row align-items-start rcom--it clln-it-bdr-btm "> <div class="flex-container-column flex"> <div class="recommender"> <a href="https://www.baltimoresun.com/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200504-y7erqozqynfgjot47n3axky2je-story.html#nt=related-content&amp;rt=chartbeat-flt"> Who will be the top rookie in fantasy? Experts debate </a> </div> <div class="timestamp clln-btm-el"> <span class="timestamp new recent"> 51m </span> </div> </div> <a href="https://www.baltimoresun.com/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200504-y7erqozqynfgjot47n3axky2je-story.html#nt=related-content&amp;rt=chartbeat-flt" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="ri-el image-xs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="Who will be the top rookie in fantasy? Experts debate" data-src="https://www.baltimoresun.com/resizer/h3VVzqbcgt2m8Wek3_QFYB0uChU=/72x72/top/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/ZOE22S7RC5HBLK5IFOWDVDXXW4.jpg" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"> </div> </figure> </a> </li> <li class="clln--it flex-container-row align-items-start rcom--it clln-it-bdr-btm "> <div class="flex-container-column flex"> <div class="recommender"> <a href="https://www.baltimoresun.com/gambling/sns-actnet-leichester-city-premier-league-greatest-longshot-betting-20200504-adttwee4kncozfl3zmfgq6jknu-story.html#nt=related-content&amp;rt=chartbeat-flt"> Rovell: What it was like to witness Leicester City’s 5000-1 stunner — the greatest longshot of all-time </a> </div> <div class="timestamp clln-btm-el"> <span class="timestamp new recent"> 52m </span> </div> </div> <a href="https://www.baltimoresun.com/gambling/sns-actnet-leichester-city-premier-league-greatest-longshot-betting-20200504-adttwee4kncozfl3zmfgq6jknu-story.html#nt=related-content&amp;rt=chartbeat-flt" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="ri-el image-xs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="Rovell: What it was like to witness Leicester City’s 5000-1 stunner — the greatest longshot of all-time" data-src="https://www.baltimoresun.com/resizer/Yv6b3ZtmNGukaMQ72le-kLRmuhI=/72x72/top/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/E2AODXZMZNEQNMPWRIIGFMRQKM.jpg" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"> </div> </figure> </a> </li> <li class="clln--it flex-container-row align-items-start rcom--it clln-it-bdr-btm lt-it"> <div class="flex-container-column flex"> <div class="recommender"> <a href="https://www.baltimoresun.com/gambling/sns-actnet-nascar-darlington-odds-kevin-harvick-kyle-busch-20200504-mbn34chflvecpf4xhunnt5idmi-story.html#nt=related-content&amp;rt=chartbeat-flt"> NASCAR at Darlington odds: Kevin Harvick and Kyle Busch co-favorites for NASCAR’s May 17 return </a> </div> <div class="timestamp clln-btm-el"> <span class="timestamp new recent"> 53m </span> </div> </div> <a href="https://www.baltimoresun.com/gambling/sns-actnet-nascar-darlington-odds-kevin-harvick-kyle-busch-20200504-mbn34chflvecpf4xhunnt5idmi-story.html#nt=related-content&amp;rt=chartbeat-flt" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="ri-el image-xs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="NASCAR at Darlington odds: Kevin Harvick and Kyle Busch co-favorites for NASCAR’s May 17 return" data-src="https://www.baltimoresun.com/resizer/ke-I4_tWuo1K0o1va1XgwG6cBEo=/72x72/top/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/RXOR2BU6JFCADHNQNDW4C4TNYU.jpg" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"> </div> </figure> </a> </li> </ul> </div> </div></div> </div> <div data-type="text" class="crd clln--it"> <div class=" crd--cnt "> <p data-item-type="depthscroll" data-item-id="depth_scroll_bottom" data-item-number="bottom"> <i>Distributed by Tribune Content Agency, LLC.</i></p> <div class="spaced spaced-md spaced-bottom hddn-mble"></div> <div class="spaced spaced-sm spaced-bottom hddn-dktp hddn-tbl"></div> </div></div> </div> </div> <div id="f0gGOPA2SrP0Xr" class="pb-async pb-feature"></div> <div id="fOOats12SrP0Xr" class="pb-async pb-feature"></div> <div class="pb-container"> </div> </section> <section id="right-rail" class="right artcl--r--sect-tmpl right-rail guttered flex-container-column"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-dfp" data-pb-name="DFP Ad" data-pb-curated="curated" data-pb-id="article-desktop-cube-right-rail" id="f0IzTxs2SrP0Xr"> <div class="pb-ad pb-ad-prod ad-300x250 hddn-mble hddn-tbl relative"> <div class="ad-caption-text align-center uppercase">Advertisement</div> <div id="hp_605" class="hddn" data-optimera-measure="trb_ad_300x600/300x250_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helai" data-ad-type="cube"> </div> </div> <script>
    (function() {
    
      
        //FetchBids for all ads
        if (true && window.apstag && true && window.headertag) {
          let params = {
            id: 'hp_605',
            slotName: '/4011/trb.baltimoresun/hp',
            includeInA9: true,
            includeInIndexExchange: true
          }
          const dimensions = !'[[300, 600], [300, 250]]'.length ? null : JSON.parse('[[300, 600], [300, 250]]'),
                sizemapDimensions = !''.length ? null : JSON.parse('')
          if (sizemapDimensions) {
            const mapping = DFPHelpers.prepareSizeMaps(dimensions, sizemapDimensions).mapping
            headerBiddingAdVendorHelpers.fetchBids(DFPHelpers.parseSizeMappings(mapping), params)
          } else {
            headerBiddingAdVendorHelpers.fetchBids(dimensions, params)
          }
        }

        
          if (trb.data.ads.optimera) {
            if (!window.oPageUnload) {
              oAv.push("trb_ad_300x600/300x250_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helai");
              oVa["trb_ad_300x600/300x250_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helai"] = ["NULL"];
            } else {
              oPageUnload('trb_ad_300x600/300x250_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helai', true);
            }
          }
        
      
      // Validation to fix ORCA-896 issue
      
        function loadAd() {
            dfpService.appendAd({
                id: 'hp_605',
                optimeraId: 'trb_ad_300x600/300x250_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helai',
                adType: 'cube',
                slotName: '/4011/trb.baltimoresun/hp',
                displayMobile: false,
                displayDesktop: true,
                isOOP: false,
                is5x1: false,
                dimensionsString: '[[300, 600], [300, 250]]',
                sizemapString: '',
                sizemapRefresh: 'false',
                refreshOnPhotoChange: false,
                adRefreshInterval: 0,
                includeInA9: true,
                includeInIndexExchange: true,
                loadImmediately: true
            }, false, true)
        }

        loadAd();
      

    })()
  </script> </div> <div class="pb-container"> <div class="wrapper clearfix col col-desktop-6 col-tablet-6 col-mobile-6 pb-feature pb-layout-item pb-f-list-recommender" data-pb-name="Recommender" data-pb-curated="automated" data-pb-id="unnamed-feature" id="fZfMP112SrP0Xr"> <div class="crd rcom--ctn flex-container-column align-items-stretch "> <div class="crd--hd flex-container-row align-items-center"> <h2 class="fte-hd">Latest Gambling</h2> </div> <div class="crd--cnt "> <ul class="list-unstyled clln clln-vtl clln-crd "> <li class="clln--it flex-container-row align-items-start rcom--it clln-it-bdr-btm "> <div class="flex-container-column flex"> <ul class="tag-list-wrapper list-unstyled flex-container-row " role="presentation"> <li> <a class="tag tag-outline tag-first" href="https://www.baltimoresun.com/gambling/#nt=taxonomy-article"> Gambling </a> </li> </ul> <div class="recommender"> <a href="https://www.baltimoresun.com/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200504-y7erqozqynfgjot47n3axky2je-story.html#nt=related-content"> Who will be the top rookie in fantasy? Experts debate </a> </div> <div class="timestamp clln-btm-el"> <span class="timestamp new recent"> 51m </span> </div> </div> <a href="https://www.baltimoresun.com/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200504-y7erqozqynfgjot47n3axky2je-story.html#nt=related-content" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="ri-el image-xs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="Who will be the top rookie in fantasy? Experts debate" data-src="https://www.baltimoresun.com/resizer/h3VVzqbcgt2m8Wek3_QFYB0uChU=/72x72/top/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/ZOE22S7RC5HBLK5IFOWDVDXXW4.jpg" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"/> </div> </figure> </a> </li> <li class="clln--it flex-container-row align-items-start rcom--it clln-it-bdr-btm "> <div class="flex-container-column flex"> <ul class="tag-list-wrapper list-unstyled flex-container-row " role="presentation"> <li> <a class="tag tag-outline tag-first" href="https://www.baltimoresun.com/gambling/#nt=taxonomy-article"> Gambling </a> </li> </ul> <div class="recommender"> <a href="https://www.baltimoresun.com/gambling/sns-actnet-leichester-city-premier-league-greatest-longshot-betting-20200504-adttwee4kncozfl3zmfgq6jknu-story.html#nt=related-content"> Rovell: What it was like to witness Leicester City’s 5000-1 stunner — the greatest longshot of all-time </a> </div> <div class="timestamp clln-btm-el"> <span class="timestamp new recent"> 52m </span> </div> </div> <a href="https://www.baltimoresun.com/gambling/sns-actnet-leichester-city-premier-league-greatest-longshot-betting-20200504-adttwee4kncozfl3zmfgq6jknu-story.html#nt=related-content" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="ri-el image-xs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="Rovell: What it was like to witness Leicester City’s 5000-1 stunner — the greatest longshot of all-time" data-src="https://www.baltimoresun.com/resizer/Yv6b3ZtmNGukaMQ72le-kLRmuhI=/72x72/top/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/E2AODXZMZNEQNMPWRIIGFMRQKM.jpg" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"/> </div> </figure> </a> </li> </ul> </div> </div> <script>document.getElementById("fZfMP112SrP0Xr").className+="desktop"=="mobile"?" hddn-dktp":"desktop"=="desktop"?" hddn-mble hddn-tbl":"";</script> <script>document.getElementById("fZfMP112SrP0Xr").className+=" hidden-mobile hidden-tablet";</script> </div> </div> <div class="hddn-mble hddn-tbl-no-overlap pb-layout-item pb-chain pb-c-floating-right-rail-chain full" style="margin-top: 75px;" id="c6VdJQ12SrP0Xr"></div> <div class="floating-chain floating-chain-wrapper-557 " data-pb-name="Floating Right-Rail Chain"> <div class="flex-grid floating-chain-557"> <section class="col col-desktop-6 col-tablet-6 col-mobile-6"> <div class="flex-grid chain-container"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-dfp" data-pb-name="DFP Ad" data-pb-curated="curated" data-pb-id="unnamed-feature" id="f0vyoui2SrP0Xr"> <div class="pb-ad pb-ad-prod ad-300x250 hddn-mble hddn-tbl relative"> <div class="ad-caption-text align-center uppercase">Advertisement</div> <div id="hp_418" class="hddn" data-optimera-measure="trb_ad_300x250_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200" data-ad-type="cube"> </div> </div> <script>
    (function() {
    
      
        //FetchBids for all ads
        if (true && window.apstag && true && window.headertag) {
          let params = {
            id: 'hp_418',
            slotName: '/4011/trb.baltimoresun/hp',
            includeInA9: true,
            includeInIndexExchange: true
          }
          const dimensions = !'[[300, 250]]'.length ? null : JSON.parse('[[300, 250]]'),
                sizemapDimensions = !''.length ? null : JSON.parse('')
          if (sizemapDimensions) {
            const mapping = DFPHelpers.prepareSizeMaps(dimensions, sizemapDimensions).mapping
            headerBiddingAdVendorHelpers.fetchBids(DFPHelpers.parseSizeMappings(mapping), params)
          } else {
            headerBiddingAdVendorHelpers.fetchBids(dimensions, params)
          }
        }

        
          if (trb.data.ads.optimera) {
            if (!window.oPageUnload) {
              oAv.push("trb_ad_300x250_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200");
              oVa["trb_ad_300x250_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200"] = ["NULL"];
            } else {
              oPageUnload('trb_ad_300x250_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200', true);
            }
          }
        
      
      // Validation to fix ORCA-896 issue
      
        function loadAd() {
            dfpService.appendAd({
                id: 'hp_418',
                optimeraId: 'trb_ad_300x250_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200',
                adType: 'cube',
                slotName: '/4011/trb.baltimoresun/hp',
                displayMobile: false,
                displayDesktop: true,
                isOOP: false,
                is5x1: false,
                dimensionsString: '[[300, 250]]',
                sizemapString: '',
                sizemapRefresh: 'false',
                refreshOnPhotoChange: false,
                adRefreshInterval: 32,
                includeInA9: true,
                includeInIndexExchange: true,
                loadImmediately: false
            }, false, false)
        }

        loadAd();
      

    })()
  </script> </div> <div class="wrapper clearfix col col-desktop-6 col-tablet-6 col-mobile-6 pb-feature pb-layout-item pb-f-list-recommender" data-pb-name="Recommender" data-pb-curated="automated" data-pb-id="unnamed-feature" id="f0PmmKX2SrP0Xr"> <div class="crd rcom--ctn flex-container-column align-items-stretch "> <div class="crd--hd flex-container-row align-items-center"> <h2 class="fte-hd">Most Read on Baltimore Sun</h2> </div> <div class="crd--cnt "> <ul class="list-unstyled clln clln-vtl clln-crd "> <li class="clln--it flex-container-row align-items-start rcom--it "> <div class="flex-container-column flex"> <ul class="tag-list-wrapper list-unstyled flex-container-row " role="presentation"> <li> <a class="tag tag-outline tag-first" href="https://www.baltimoresun.com/coronavirus/#nt=taxonomy-article"> Coronavirus </a> </li> </ul> <div class="recommender"> <a href="https://www.baltimoresun.com/coronavirus/bs-md-coronavirus-monday-20200504-yijycxipxzbznkpnpap2jesmtm-story.html#nt=related-content&amp;rt=chartbeat-flt"> Rate of coronavirus hospitalizations, intensive cases flat in Maryland, deaths increase 10% </a> </div> <div class="timestamp clln-btm-el"> <span class="timestamp recent"> 1h </span> </div> </div> <a href="https://www.baltimoresun.com/coronavirus/bs-md-coronavirus-monday-20200504-yijycxipxzbznkpnpap2jesmtm-story.html#nt=related-content&amp;rt=chartbeat-flt" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="ri-el image-xs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="Rate of coronavirus hospitalizations, intensive cases flat in Maryland, deaths increase 10%" data-src="https://www.baltimoresun.com/resizer/pxS1tSrDsTBkWWCCnZJYbfdCRIQ=/72x72/top/www.baltimoresun.com/resizer/VDsk3Rgxd4Ph7Buov6P_c8K5lxQ=/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/G3R3LAMWWBEKLB64MKATQFSJNU.jpg" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"> </div> </figure> </a> </li> <li class="clln--it flex-container-row align-items-start rcom--it "> <div class="flex-container-column flex"> <ul class="tag-list-wrapper list-unstyled flex-container-row " role="presentation"> <li> <a class="tag tag-outline tag-first" href="https://www.baltimoresun.com/sports/ravens/#nt=taxonomy-article"> Baltimore Ravens </a> </li> </ul> <div class="recommender"> <a href="https://www.baltimoresun.com/sports/ravens/bs-sp-don-shula-colts-obit-20200504-nyhqgmtfizaejljik44kk5jvuy-story.html#nt=related-content&amp;rt=chartbeat-flt"> Hall of Fame coach Don Shula, who won NFL championship with Baltimore Colts, dies </a> </div> <div class="timestamp clln-btm-el"> <span class="timestamp recent"> 1h </span> </div> </div> <a href="https://www.baltimoresun.com/sports/ravens/bs-sp-don-shula-colts-obit-20200504-nyhqgmtfizaejljik44kk5jvuy-story.html#nt=related-content&amp;rt=chartbeat-flt" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="ri-el image-xs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="Hall of Fame coach Don Shula, who won NFL championship with Baltimore Colts, dies" data-src="https://www.baltimoresun.com/resizer/cALXPRro5Xn6N2Dit7bs9DBznjE=/72x72/top/www.baltimoresun.com/resizer/93BNAEtdpn6wXFWtwHKi1nfs78k=/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/VKGQSAYBGZFMNOCTKNXIAVCEVU.jpg" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"> </div> </figure> </a> </li> </ul> </div> </div> <script>document.getElementById("f0PmmKX2SrP0Xr").className+="desktop"=="mobile"?" hddn-dktp":"desktop"=="desktop"?" hddn-mble hddn-tbl":"";</script> <script>document.getElementById("f0PmmKX2SrP0Xr").className+=" hidden-mobile hidden-tablet";</script> </div> </div> </section> </div> </div> <script>
  ;(function() {
    let previousBreakpoint = null;
    let appBarMutationObAdded;
    const floatingChainWrapper = document.querySelector(".floating-chain-wrapper-557");
    const closeTrayEl = document.querySelector('div[data-role="close-tray"]');

    function initFloatingChain() {
      const viewportWidth = window.innerWidth || document.documentElement.clientWidth || document.body.clientWidth;

      // Only set "floating" functionality on desktop
      if (viewportWidth >= 800 && checkBreakpointChange('desktop')) {
        setFloatingChainStyles(true);
      } else if (viewportWidth < 800 && checkBreakpointChange('mobile')) {
        setFloatingChainStyles(false);
      }
    }
    
    function handleAppBarMutations() {
      appBarMutationObAdded = true
      const appBar = document.getElementById('app-bar-sticky');
      if (appBar) {
        let appBarHeight;
        let observer = new MutationObserver(function(mutations) {
          mutations.forEach(function(mutation) {
            let currentAppBarHeight = appBar.clientHeight
            if (currentAppBarHeight !== appBarHeight) {
              floatingChainWrapper.style.top = currentAppBarHeight + 0 + 'px'
              appBarHeight = currentAppBarHeight
            }
          });
        });
        observer.observe(appBar, { attributes: true, childList: true });
      }
    }

    function checkBreakpointChange(currentBreakpoint) {
      const isBreakpointChanged = !previousBreakpoint || previousBreakpoint !== currentBreakpoint;
      previousBreakpoint = currentBreakpoint;
      return isBreakpointChanged;
    }

    function setFloatingChainStyles(setToSticky) {
      const classListAction = setToSticky ? 'add' : 'remove';
      if (closeTrayEl) {
          closeTrayEl.classList[classListAction]('overflow-x-inherit');
      }
      floatingChainWrapper.classList[classListAction]('sticky');
      floatingChainWrapper.classList[classListAction]('z-index-29');

      // Add mutation observer to check if the height of appbar changes
      setToSticky ? !appBarMutationObAdded && handleAppBarMutations() : floatingChainWrapper.style.top = '0'
    }

    initFloatingChain();
    window.addEventListener('resize', initFloatingChain);
  })();
</script> <div class="pb-container"> </div> </section> </main> <div class="artcl--r-sp"> <aside id="left-bottom" class="artcl--sect-tmpl left guttered"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-taboola" data-pb-name="Taboola" data-pb-curated="curated" data-pb-id="article-taboola" id="f0dTPeN2SrP0Xr"> <div id="article_1615" class="taboola-container " data-vendor-taboolacontenttype="article" data-ad-loadimmediately="true" data-vendor-placement="" data-vendor-mode="" data-vendor-pagetype=""> </div> <script>(function(){trb.ads.taboola=trb.ads.taboola||[];trb.ads.taboola.push(document.getElementById("article_1615"))})();</script> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-test-html-box" data-pb-name="Html Box" data-pb-curated="curated" data-pb-id="taboola-skip-wrapper-2" id="f9t50M12SrP0Xr"> <div class="taboola-skip-wrapper" style="width:100%; max-width: 801px"> <div id="taboola-skip-2"></div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-dfp" data-pb-name="DFP Ad" data-pb-curated="curated" data-pb-id="article-desktop-bottom-leaderboard" id="f0R4GNd2SrP0Xr"> <div class="pb-ad pb-ad-prod ad-320x50 hddn-mble hddn-tbl relative"> <div class="ad-caption-text align-center uppercase">Advertisement</div> <div id="hp_1307" class="hddn" data-optimera-measure="trb_ad_728x90/320x50_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire" data-ad-type="leaderboard"> </div> </div> <script>
    (function() {
    
      
        //FetchBids for all ads
        if (true && window.apstag && true && window.headertag) {
          let params = {
            id: 'hp_1307',
            slotName: '/4011/trb.baltimoresun/hp',
            includeInA9: true,
            includeInIndexExchange: true
          }
          const dimensions = !' [[[728, 90]], [[320, 50]]] '.length ? null : JSON.parse(' [[[728, 90]], [[320, 50]]] '),
                sizemapDimensions = !'[[1200, 0], [0, 0]]'.length ? null : JSON.parse('[[1200, 0], [0, 0]]')
          if (sizemapDimensions) {
            const mapping = DFPHelpers.prepareSizeMaps(dimensions, sizemapDimensions).mapping
            headerBiddingAdVendorHelpers.fetchBids(DFPHelpers.parseSizeMappings(mapping), params)
          } else {
            headerBiddingAdVendorHelpers.fetchBids(dimensions, params)
          }
        }

        
          if (trb.data.ads.optimera) {
            if (!window.oPageUnload) {
              oAv.push("trb_ad_728x90/320x50_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire");
              oVa["trb_ad_728x90/320x50_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire"] = ["NULL"];
            } else {
              oPageUnload('trb_ad_728x90/320x50_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire', true);
            }
          }
        
      
      // Validation to fix ORCA-896 issue
      
        function loadAd() {
            dfpService.appendAd({
                id: 'hp_1307',
                optimeraId: 'trb_ad_728x90/320x50_1_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire',
                adType: 'leaderboard',
                slotName: '/4011/trb.baltimoresun/hp',
                displayMobile: false,
                displayDesktop: true,
                isOOP: false,
                is5x1: false,
                dimensionsString: ' [[[728, 90]], [[320, 50]]] ',
                sizemapString: '[[1200, 0], [0, 0]]',
                sizemapRefresh: 'true',
                refreshOnPhotoChange: false,
                adRefreshInterval: 0,
                includeInA9: true,
                includeInIndexExchange: true,
                isMobileSticky: false,
                loadImmediately: false,
                adLite: 'hide'
            }, false, false)
        }

        loadAd();
      

    })()
  </script> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-test-html-box" data-pb-name="Html Box" data-pb-curated="curated" data-pb-id="taboola-skip-wrapper" id="f0J8tkX2SrP0Xr"> <div class="taboola-skip-wrapper" style="width:100%; max-width: 801px"> <div id="taboola-skip"></div> </div> </div> <div class="pb-container"> <div class="wrapper clearfix col col-desktop-6 col-tablet-6 col-mobile-6 pb-feature pb-layout-item pb-f-article-article-recommender" data-pb-name="Mobile Floating Recommender" data-pb-curated="curated" data-pb-id="unnamed-feature" id="fwj8aN12SrP0Xr"> <div class="floating-article-recommender width-100 hddn hddn-dktp hddn-tbl"> <div class="article-label"> Most Read • Gambling </div> <div class="home-link"> <a href="/#nt=floating-rec-nav">Return Home</a> </div> <div class="trb--cl"> <svg class="icon-light icon-margin-auto icon-14-27" focusable="false"> <use xlink:href="#close"/> </svg> </div> <div class="blurb-box with-image"> <a href="https://www.baltimoresun.com/gambling/sns-actnet-denver-broncos-draft-picks-grades-20200503-wxa5yzep5bbhbp22d7cveakncq-story.html#nt=floating-rec-content"> Grading Broncos draft picks: Why Denver should be optimistic about this 2020 class </a> </div> <div class="image-box aspect-ratio-1x1"> <a href="https://www.baltimoresun.com/gambling/sns-actnet-denver-broncos-draft-picks-grades-20200503-wxa5yzep5bbhbp22d7cveakncq-story.html#nt=floating-rec-content"> <img src="https://www.baltimoresun.com/resizer/dNLis2ToOjX-qO8wMV44K4HTw7s=/90x90/top/www.baltimoresun.com/resizer/igEC8RIAnvEmWJaegIM6ii9YthU=/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/UIYS4SRICNEK5OZBM2LV46MSGY.jpg"/> </a> </div> </div> </div> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-test-html-box" data-pb-name="Html Box" data-pb-curated="curated" data-pb-id="css-viafoura-hide-voting" id="fWyD7312SrP0Xr"> <style>.viafoura .vf-content-actions .vf-content-actions__left-actions{display:none}</style> </div> </div> </aside> <aside id="right-rail-bottom" class="right artcl--r--sect-tmpl right-rail guttered flex-container-column"> <div class="pb-container"> <div class="wrapper clearfix col col-desktop-6 col-tablet-6 col-mobile-6 pb-feature pb-layout-item pb-f-ads-taboola" data-pb-name="Taboola" data-pb-curated="curated" data-pb-id="unnamed-feature" id="f7Ukhk22SrP0Xr"> <div id="article_373" class="taboola-container desktop-only" data-vendor-taboolacontenttype="article" data-ad-loadimmediately="true" data-vendor-placement="" data-vendor-mode="" data-vendor-pagetype=""> </div> <script>(function(){trb.ads.taboola=trb.ads.taboola||[];trb.ads.taboola.push(document.getElementById("article_373"))})();</script> </div> </div> <div class="hddn-mble hddn-tbl-no-overlap pb-layout-item pb-chain pb-c-floating-right-rail-chain full" style="margin-top: 50px;" id="cWrTkB12SrP0Xr"></div> <div class="floating-chain floating-chain-wrapper-1649 " data-pb-name="Floating Right-Rail Chain"> <div class="flex-grid floating-chain-1649"> <section class="col col-desktop-6 col-tablet-6 col-mobile-6"> <div class="flex-grid chain-container"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-dfp" data-pb-name="DFP Ad" data-pb-curated="curated" data-pb-id="unnamed-feature" id="f0fqaCw2SrP0Xr"> <div class="pb-ad pb-ad-prod ad-300x250 hddn-mble hddn-tbl relative"> <div class="ad-caption-text align-center uppercase">Advertisement</div> <div id="hp_1337" class="hddn" data-optimera-measure="trb_ad_300x250_2_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200" data-ad-type="cube"> </div> </div> <script>
    (function() {
    
      
        //FetchBids for all ads
        if (true && window.apstag && true && window.headertag) {
          let params = {
            id: 'hp_1337',
            slotName: '/4011/trb.baltimoresun/hp',
            includeInA9: true,
            includeInIndexExchange: true
          }
          const dimensions = !'[[300, 250]]'.length ? null : JSON.parse('[[300, 250]]'),
                sizemapDimensions = !''.length ? null : JSON.parse('')
          if (sizemapDimensions) {
            const mapping = DFPHelpers.prepareSizeMaps(dimensions, sizemapDimensions).mapping
            headerBiddingAdVendorHelpers.fetchBids(DFPHelpers.parseSizeMappings(mapping), params)
          } else {
            headerBiddingAdVendorHelpers.fetchBids(dimensions, params)
          }
        }

        
          if (trb.data.ads.optimera) {
            if (!window.oPageUnload) {
              oAv.push("trb_ad_300x250_2_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200");
              oVa["trb_ad_300x250_2_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200"] = ["NULL"];
            } else {
              oPageUnload('trb_ad_300x250_2_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200', true);
            }
          }
        
      
      // Validation to fix ORCA-896 issue
      
        function loadAd() {
            dfpService.appendAd({
                id: 'hp_1337',
                optimeraId: 'trb_ad_300x250_2_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire-20200',
                adType: 'cube',
                slotName: '/4011/trb.baltimoresun/hp',
                displayMobile: false,
                displayDesktop: true,
                isOOP: false,
                is5x1: false,
                dimensionsString: '[[300, 250]]',
                sizemapString: '',
                sizemapRefresh: 'false',
                refreshOnPhotoChange: false,
                adRefreshInterval: 32,
                includeInA9: true,
                includeInIndexExchange: true,
                loadImmediately: false
            }, false, false)
        }

        loadAd();
      

    })()
  </script> </div> <div class="wrapper clearfix col col-desktop-6 col-tablet-6 col-mobile-6 pb-feature pb-layout-item pb-f-list-recommender" data-pb-name="Recommender" data-pb-curated="automated" data-pb-id="unnamed-feature" id="fglCx712SrP0Xr"> <div class="crd rcom--ctn flex-container-column align-items-stretch "> <div class="crd--hd flex-container-row sd-pdd-only align-items-center"> <div class="flex"> <h2 class="rcom--hd"> <a newwindow="false" href="/trending#nt=recommender-header" class="rcom--lnk"> <span>Most Read • Maryland</span> <span class="visually-hidden">See more Most Read • Maryland articles</span> <button name="clickthroughLink" class="button-icon svg-c" role="link" tabindex="-1" aria-hidden="true"> <svg class="icon-10-27" aria-hidden="true" focusable="false"> <use xlink:href="#angle-right"/> </svg> </button> </a> </h2> </div> </div> <div class="crd--cnt "> <ul class="list-unstyled clln clln-vtl clln-crd "> <li class="clln--it flex-container-row align-items-start rcom--it clln-it-bdr-btm "> <div class="flex-container-column flex"> <ul class="tag-list-wrapper list-unstyled flex-container-row " role="presentation"> <li> <a class="tag tag-outline tag-first" href="https://www.baltimoresun.com/coronavirus/#nt=taxonomy-article"> Coronavirus </a> </li> </ul> <div class="recommender"> <a href="https://www.baltimoresun.com/coronavirus/cc-covid19-plasma-therapy-carroll-20200504-uqkdx7aypnehfiq3p7yyrl2smq-story.html#nt=latestnews&amp;rt=chartbeat-flt"> Blood of those recovered from COVID-19 could ‘head the disease off at the pass,’ health experts say </a> </div> <div class="timestamp clln-btm-el"> <span class="timestamp new recent"> 36m </span> </div> </div> <a href="https://www.baltimoresun.com/coronavirus/cc-covid19-plasma-therapy-carroll-20200504-uqkdx7aypnehfiq3p7yyrl2smq-story.html#nt=latestnews&amp;rt=chartbeat-flt" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="ri-el image-xs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="Blood of those recovered from COVID-19 could ‘head the disease off at the pass,’ health experts say" data-src="https://www.baltimoresun.com/resizer/2AIIxphJfOtbbFE4V8uzgyKFOhc=/72x72/top/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/XRNKHHM275HTRKQDCD2RGITEUQ.jpg" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"> </div> </figure> </a> </li> <li class="clln--it flex-container-row align-items-start rcom--it clln-it-bdr-btm "> <div class="flex-container-column flex"> <ul class="tag-list-wrapper list-unstyled flex-container-row " role="presentation"> <li> <a class="tag tag-outline tag-first" href="https://www.baltimoresun.com/politics/#nt=taxonomy-article"> Politics </a> </li> </ul> <div class="recommender"> <a href="https://www.baltimoresun.com/politics/bs-md-pol-kweisi-mfume-congress-swearing-in-20200504-ma6jbyic2neilbfadt4cf3enkm-story.html#nt=latestnews&amp;rt=chartbeat-flt"> Baltimore’s Kweisi Mfume to be sworn in Tuesday as Maryland’s newest congressman </a> </div> <div class="timestamp clln-btm-el"> <span class="timestamp recent"> 1h </span> </div> </div> <a href="https://www.baltimoresun.com/politics/bs-md-pol-kweisi-mfume-congress-swearing-in-20200504-ma6jbyic2neilbfadt4cf3enkm-story.html#nt=latestnews&amp;rt=chartbeat-flt" tabindex="-1"> <figure class="" data-trk-photo-credit=""> <div class="ri-el image-xs img-container aspect-ratio-1x1"> <img class="b-lazy full-width" alt="Baltimore’s Kweisi Mfume to be sworn in Tuesday as Maryland’s newest congressman" data-src="https://www.baltimoresun.com/resizer/Xyjjm3cyBAkKLsyPh5bsT-yjJrk=/72x72/top/arc-anglerfish-arc2-prod-tronc.s3.amazonaws.com/public/URKM6VGSSSERERMJFFKEOAYHLU.aspx" data-src-small="" data-src-medium="" data-src-mobile="" src="/pb/resources/images/tinygif.gif"> </div> </figure> </a> </li> </ul> </div> </div> <script>document.getElementById("fglCx712SrP0Xr").className+="both"=="mobile"?" hddn-dktp":"both"=="desktop"?" hddn-mble hddn-tbl":"";</script> <script>document.getElementById("fglCx712SrP0Xr").className+="";</script> </div> </div> </section> </div> </div> <script>
  ;(function() {
    let previousBreakpoint = null;
    let appBarMutationObAdded;
    const floatingChainWrapper = document.querySelector(".floating-chain-wrapper-1649");
    const closeTrayEl = document.querySelector('div[data-role="close-tray"]');

    function initFloatingChain() {
      const viewportWidth = window.innerWidth || document.documentElement.clientWidth || document.body.clientWidth;

      // Only set "floating" functionality on desktop
      if (viewportWidth >= 800 && checkBreakpointChange('desktop')) {
        setFloatingChainStyles(true);
      } else if (viewportWidth < 800 && checkBreakpointChange('mobile')) {
        setFloatingChainStyles(false);
      }
    }
    
    function handleAppBarMutations() {
      appBarMutationObAdded = true
      const appBar = document.getElementById('app-bar-sticky');
      if (appBar) {
        let appBarHeight;
        let observer = new MutationObserver(function(mutations) {
          mutations.forEach(function(mutation) {
            let currentAppBarHeight = appBar.clientHeight
            if (currentAppBarHeight !== appBarHeight) {
              floatingChainWrapper.style.top = currentAppBarHeight + 0 + 'px'
              appBarHeight = currentAppBarHeight
            }
          });
        });
        observer.observe(appBar, { attributes: true, childList: true });
      }
    }

    function checkBreakpointChange(currentBreakpoint) {
      const isBreakpointChanged = !previousBreakpoint || previousBreakpoint !== currentBreakpoint;
      previousBreakpoint = currentBreakpoint;
      return isBreakpointChanged;
    }

    function setFloatingChainStyles(setToSticky) {
      const classListAction = setToSticky ? 'add' : 'remove';
      if (closeTrayEl) {
          closeTrayEl.classList[classListAction]('overflow-x-inherit');
      }
      floatingChainWrapper.classList[classListAction]('sticky');
      floatingChainWrapper.classList[classListAction]('z-index-29');

      // Add mutation observer to check if the height of appbar changes
      setToSticky ? !appBarMutationObAdded && handleAppBarMutations() : floatingChainWrapper.style.top = '0'
    }

    initFloatingChain();
    window.addEventListener('resize', initFloatingChain);
  })();
</script> <div class="pb-container"> </div> </aside> </div> </article> <section id="bottom" class="full-columns container"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-dfp" data-pb-name="DFP Ad" data-pb-curated="curated" data-pb-id="article-desktop-bottom-leaderboard-mobile" id="f9DjTb12SrP0Xr"> <div class="pb-ad pb-ad-prod ad-320x50 hddn-dktp relative&#32;trb_ad_st_m stuck hddn-dktp"> <div class="ad-caption-text align-center uppercase">Advertisement</div> <div class="trb_st_cl " tabindex="0" aria-label="Close Ad" role="button" aria-pressed="false"> <svg class="closeSticky" focusable="false"> <use xlink:href="#close-sticky"/> </svg> </div> <div id="hp_1001" class="hddn" data-optimera-measure="trb_ad_728x90/320x50_2_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire" data-ad-mobile-sticky> </div> </div> <script>
    (function() {
    
      
        //FetchBids for all ads
        if (true && window.apstag && true && window.headertag) {
          let params = {
            id: 'hp_1001',
            slotName: '/4011/trb.baltimoresun/hp',
            includeInA9: true,
            includeInIndexExchange: true
          }
          const dimensions = !' [[[728, 90]], [[320, 50]]] '.length ? null : JSON.parse(' [[[728, 90]], [[320, 50]]] '),
                sizemapDimensions = !'[[1200, 0], [0, 0]]'.length ? null : JSON.parse('[[1200, 0], [0, 0]]')
          if (sizemapDimensions) {
            const mapping = DFPHelpers.prepareSizeMaps(dimensions, sizemapDimensions).mapping
            headerBiddingAdVendorHelpers.fetchBids(DFPHelpers.parseSizeMappings(mapping), params)
          } else {
            headerBiddingAdVendorHelpers.fetchBids(dimensions, params)
          }
        }

        
          if (trb.data.ads.optimera) {
            if (!window.oPageUnload) {
              oAv.push("trb_ad_728x90/320x50_2_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire");
              oVa["trb_ad_728x90/320x50_2_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire"] = ["NULL"];
            } else {
              oPageUnload('trb_ad_728x90/320x50_2_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire', true);
            }
          }
        
      
      // Validation to fix ORCA-896 issue
      
        function loadAd() {
            dfpService.appendAd({
                id: 'hp_1001',
                optimeraId: 'trb_ad_728x90/320x50_2_/gambling/sns-actnet-rookie-fantasy-football-joe-burrow-clyde-edwards-helaire',
                adType: 'leaderboard',
                slotName: '/4011/trb.baltimoresun/hp',
                displayMobile: true,
                displayDesktop: false,
                isOOP: false,
                is5x1: false,
                dimensionsString: ' [[[728, 90]], [[320, 50]]] ',
                sizemapString: '[[1200, 0], [0, 0]]',
                sizemapRefresh: 'true',
                refreshOnPhotoChange: false,
                adRefreshInterval: 32,
                includeInA9: true,
                includeInIndexExchange: true,
                isMobileSticky: true,
                loadImmediately: true,
                adLite: 'hide'
            }, false, true)
        }

        loadAd();
      

    })()
  </script> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-dfp" data-pb-name="DFP Ad" data-pb-curated="curated" data-pb-id="article-responsive-teads-tout" id="f9ZydV12SrP0Xr"> <div class="pb-ad pb-ad-prod ad-5x1 hddn"> <div id="hp_1526" class="hddn" data-ad-type="teads-and-tout"> </div> </div> <script>(function(){function loadAd(){dfpService.appendAd({id:"hp_1526",optimeraId:"",adType:"teads-and-tout",slotName:"/4011/trb.baltimoresun/hp",displayMobile:true,displayDesktop:true,isOOP:false,is5x1:true,dimensionsString:"[[5, 1]]",sizemapString:"",sizemapRefresh:"false",refreshOnPhotoChange:false,adRefreshInterval:0,includeInA9:false,includeInIndexExchange:false,loadImmediately:true,adLite:"true"},false,true)}loadAd()})();</script> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-dfp" data-pb-name="DFP Ad" data-pb-curated="curated" data-pb-id="article-responsive-oop" id="f0zCrVY2SrP0Xr"> <div class="pb-ad pb-ad-prod ad-reskin pb-ad-oop hddn"> <div id="hp_1510" class="hddn" data-ad-type="reskin"> </div> </div> <script>(function(){function loadAd(){dfpService.appendAd({id:"hp_1510",optimeraId:"",adType:"reskin",slotName:"/4011/trb.baltimoresun/hp",displayMobile:true,displayDesktop:true,isOOP:true,is5x1:false,dimensionsString:"",sizemapString:"",sizemapRefresh:"false",refreshOnPhotoChange:false,adRefreshInterval:0,includeInA9:false,includeInIndexExchange:false,loadImmediately:true},false,true)}loadAd()})();</script> </div> <div class="pb-container"> <div class="wrapper clearfix col col-desktop-6 col-tablet-6 col-mobile-6 pb-feature pb-layout-item pb-f-ads-dfp" data-pb-name="DFP Ad" data-pb-curated="curated" data-pb-id="article-amp-sticky" id="f0esGY12SrP0Xr"> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-test-html-box" data-pb-name="Html Box" data-pb-curated="curated" data-pb-id="css-hide-in-body-recommender-desktop-tablet" id="f02LVup2SrP0Xr"> <style>@media only screen and (min-width:415px){.wrapper.pb-f-article-body [data-type="recommender"]{display:none}}</style> </div> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-test-html-box" data-pb-name="Html Box" data-pb-curated="curated" data-pb-id="script-paywall-free-message" id="f0YT5te2SrP0Xr"> <script>(function(){var msg='\x3cp\x3eCareFirst BlueCross BlueShield is partnering with The Baltimore Sun to make this important information paywall-free for non-subscribers. To support essential reporting, please consider \x3ca href\x3d"http://join.baltimoresun.com/#int\x3dbs_digitaladshouse_editorial_support_bxca" target\x3d"_blank"\x3e becoming a subscriber\x3c/a\x3e.\x3c/p\x3e';var isShow=""==="true";var pageLoadCat=window.trb&&trb.data&&trb.data.page.metrics&&trb.data.page.metrics.pageLoadCat,selector=
".artcl--sect-tmpl",sStatus,i=0,l=5;var trbMsgInt=setInterval(function(){i++;console.log("attempt: "+i);if(window.registration||i>l)clearInterval(trbMsgInt);(window.registration||(window.registration=[])).push({user:function(u){var sStatus=u.isLoggedIn();var isFree=window.trb&&trb.data&&trb.data.dssOverrideLevelCode&&trb.data.dssOverrideLevelCode==="free";var msgExists=document.getElementById("trbArticleMsg");if(isShow&&!sStatus&&isFree&&!msgExists){var targetContainer=document.querySelector(selector);
if(targetContainer){var wrapper=document.createElement("div");wrapper.classList.add("screamer-wrapper");var elem=document.createElement("div");elem.id="trbArticleMsg";elem.classList.add("wrapper","clearfix","full","crd--cnt","pb-feature","pb-layout-item","advisory-yellow");elem.style.padding="10px 10px 10px 10px";elem.innerHTML=msg;wrapper.appendChild(elem);targetContainer.firstChild.parentElement.insertBefore(wrapper,targetContainer.firstChild)}}}})},1E3)})();</script> </div> </div> <div id="fIzKk512SrP0Xr" class="pb-async pb-feature"></div> <div class="pb-container"> </div> </section> </div> </div> <script>var pb_global={pageName:"baltimore-detail-article-floating-right-rail",pageId:"r0tXAvouN45LXr",contextPath:"/pb",isAdmin:false,layoutEngineName:"",environment:"production",resourceToken:""};</script> <script>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</script> <script>window.banditoEnv={TIMEOUT:1500,PERF_API:"https://bandito-events-prod.tronc.arcpublishing.com/api/save-perf",TESTS_API:"https://bandito-tests.tronc.arcpublishing.com/tests-pb/",EVENTS_API:"https://bandito-events-prod.tronc.arcpublishing.com/api/save-event"};if(window["pageBuilder"]&&window["pageBuilder"]["initVariants"])window.pageBuilder.initVariants({IS_ADMIN:false,TIMEOUT:window.banditoEnv.TIMEOUT,PERF_API:window.banditoEnv.PERF_API,TESTS_API:window.banditoEnv.TESTS_API,EVENTS_API:window.banditoEnv.EVENTS_API});</script> <script>(function(){var topics=[];topics.push("ap");var keywords=[];keywords.push("burrow");keywords.push("rookie");keywords.push("season");keywords.push("luck");keywords.push("akers");keywords.push("game");keywords.push("fantasy");keywords.push("williams");keywords.push("college");keywords.push("round");keywords.push("pick");keywords.push("receiver");keywords.push("ceh");keywords.push("edwards-helaire");keywords.push("team");keywords.push("yards");keywords.push("yard");keywords.push("nfl");keywords.push("Burrow");
keywords.push("draft");keywords.push("opportunity");keywords.push("lsu");keywords.push("talent");keywords.push("sean");keywords.push("bengals");var auxiliaries=[];window.clavis={site:"baltimore-sun",topics:topics,keywords:keywords,auxiliaries:auxiliaries,contentId:"Y7ERQOZQYNFGJOT47N3AXKY2JE",targetingUrl:"https://targeting.tronc.arcpublishing.com/TargetingWebAPP/targeting"}})();</script> <script async src='/pb/gr/p/default/r0tXAvouN45LXr/render.js?v=224'></script><div class="sidebar-mask" data-role="close-tray"/> <script>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</script> <script>trb.data.page.metrics.mather.video=true;</script><script>trb.data.page.metrics.mather.artupt="2020-05-04 12:10:58-04:00";trb.data.page.metrics.mather.artpub="2020-05-04 12:10:57-04:00";trb.data.page.metrics.mather.chrcnt="8710";trb.data.page.metrics.mather.paracnt="42";trb.data.page.metrics.mather.wrdcnt="1534";</script><script>trb.data.page.metrics.characterCount="8710";</script><script data-template-id="topics-list" type="text/template">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</script></body> </html> <script>window.dataLayer=window.dataLayer||[];window.dataLayer.push({"event":"optimize.activate"});</script><script>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</script>